summaryrefslogtreecommitdiffstats
path: root/debian/patches/debian/0002-zupdate.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/debian/0002-zupdate.patch')
-rw-r--r--debian/patches/debian/0002-zupdate.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/patches/debian/0002-zupdate.patch b/debian/patches/debian/0002-zupdate.patch
new file mode 100644
index 0000000..f434707
--- /dev/null
+++ b/debian/patches/debian/0002-zupdate.patch
@@ -0,0 +1,15 @@
+Author: Daniel Baumann <mail@daniel-baumann.ch>
+Description: Avoid linking zupdate statically.
+
+diff -Naurp zutils.orig/Makefile.in zutils/Makefile.in
+--- zutils.orig/Makefile.in
++++ zutils/Makefile.in
+@@ -51,7 +51,7 @@ ztest : $(ztest_objs)
+ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o $@ $(ztest_objs)
+
+ zupdate : $(zupdate_objs)
+- $(CXX) $(LDFLAGS) $(CXXFLAGS) -o $@ $(zupdate_objs)
++ $(CXX) $(CXXFLAGS) -o $@ $(zupdate_objs)
+
+ rc.o : rc.cc
+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -DPROGVERSION=\"$(pkgversion)\" -DSYSCONFDIR=\"$(sysconfdir)\" -c -o $@ $<