summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:56:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:56:05 +0000
commit98581ac80d7672e9a7280a618d1f8d77c7bd47db (patch)
tree7821dc56cc35a56c0ec5c4f0ce1ed51865384d80
parentMerging upstream version 2.16.5. (diff)
downloadansible-core-98581ac80d7672e9a7280a618d1f8d77c7bd47db.tar.xz
ansible-core-98581ac80d7672e9a7280a618d1f8d77c7bd47db.zip
Merging debian version 2.16.5-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog11
-rw-r--r--debian/control6
-rw-r--r--debian/gbp.conf3
-rw-r--r--debian/patches/0005-use-py3.patch45
-rw-r--r--debian/patches/0009-resolvelib_compat.patch113
-rw-r--r--debian/patches/0010-fix-facter.patch87
-rw-r--r--debian/patches/series2
-rw-r--r--debian/watch2
8 files changed, 18 insertions, 251 deletions
diff --git a/debian/changelog b/debian/changelog
index 46e5ced..9586af3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+ansible-core (2.16.5-1) unstable; urgency=medium
+
+ * New upstream release (Closes: #1057640)
+ - ansible-test supports python 3.12 now (Closes: #1061782, #1061781)
+ - fixes CVE-2024-0690 (Closes: #1061156)
+ * Drop dependency on python3-distutils (Closes: #1065826)
+ * Drop patches applied upstream
+ * Refreshen patches
+
+ -- Lee Garrett <debian@rocketjump.eu> Wed, 17 Apr 2024 23:47:08 +0200
+
ansible-core (2.14.13-1~progress7.99u1) graograman-backports; urgency=medium
* Initial reupload to graograman-backports.
diff --git a/debian/control b/debian/control
index 9fc73ac..c4738a7 100644
--- a/debian/control
+++ b/debian/control
@@ -1,7 +1,8 @@
Source: ansible-core
Maintainer: Progress Linux Maintainers <maintainers@lists.progress-linux.org>
XSBC-Uploaders: Daniel Baumann <daniel.baumann@progress-linux.org>
-XSBC-Original-Maintainer: Lee Garrett <debian@rocketjump.eu>
+XSBC-Original-Maintainer: Debian Python Team <team+python@tracker.debian.org>
+XSBC-Original-Uploaders: Lee Garrett <debian@rocketjump.eu>
Bugs: mailto:maintainers@lists.progress-linux.org
Section: admin
Priority: optional
@@ -37,13 +38,12 @@ Architecture: all
Depends: ${misc:Depends},
${python3:Depends},
openssh-client | python3-paramiko (>= 2.6.0),
- python3-distutils,
python3-dnspython,
python3-httplib2,
python3-jinja2 (>= 3.0.0~),
python3-netaddr,
python3-yaml (>= 5.1~)
-Recommends: ansible (>= 7.0.0-1~),
+Recommends: ansible (>= 9.4.0-1~),
python3-argcomplete,
python3-cryptography,
python3-jmespath,
diff --git a/debian/gbp.conf b/debian/gbp.conf
index 12c6021..514ccaf 100644
--- a/debian/gbp.conf
+++ b/debian/gbp.conf
@@ -4,3 +4,6 @@
debian-branch = debian/latest
upstream-branch = upstream/latest
pristine-tar = True
+
+[import-orig]
+merge-mode = replace
diff --git a/debian/patches/0005-use-py3.patch b/debian/patches/0005-use-py3.patch
index 873918f..0db80e1 100644
--- a/debian/patches/0005-use-py3.patch
+++ b/debian/patches/0005-use-py3.patch
@@ -40,21 +40,6 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
# -*- coding: utf-8 -*-
---- a/test/integration/targets/group/files/gidget.py
-+++ b/test/integration/targets/group/files/gidget.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
-
- from __future__ import (absolute_import, division, print_function)
- __metaclass__ = type
---- a/test/integration/targets/module_utils/module_utils/foo.py
-+++ b/test/integration/targets/module_utils/module_utils/foo.py
-@@ -1,3 +1,3 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
-
- foo = "FOO FROM foo.py"
--- a/test/integration/targets/module_utils/module_utils/sub/bam.py
+++ b/test/integration/targets/module_utils/module_utils/sub/bam.py
@@ -1,3 +1,3 @@
@@ -69,20 +54,6 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+#!/usr/bin/env python3
bam = "BAM FROM sub/bam/bam.py"
---- a/test/integration/targets/module_utils/module_utils/sub/bar/bam.py
-+++ b/test/integration/targets/module_utils/module_utils/sub/bar/bam.py
-@@ -1,3 +1,3 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
-
- bam = "BAM FROM sub/bar/bam.py"
---- a/test/integration/targets/module_utils/module_utils/sub/bar/bar.py
-+++ b/test/integration/targets/module_utils/module_utils/sub/bar/bar.py
-@@ -1,3 +1,3 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
-
- bar = "BAR FROM sub/bar/bar.py"
--- a/test/integration/targets/pause/test-pause.py
+++ b/test/integration/targets/pause/test-pause.py
@@ -1,4 +1,4 @@
@@ -218,22 +189,6 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
assert set(inv['_meta']['hostvars']['test_host']['departments']) == set(['paris'])"
export ANSIBLE_CACHE_PLUGINS=cache_plugins/
---- a/test/units/modules/test_async_wrapper.py
-+++ b/test/units/modules/test_async_wrapper.py
-@@ -22,11 +22,11 @@
- def test_run_module(self, monkeypatch):
-
- def mock_get_interpreter(module_path):
-- return ['/usr/bin/python']
-+ return ['/usr/bin/python3']
-
- module_result = {'rc': 0}
- module_lines = [
-- '#!/usr/bin/python',
-+ '#!/usr/bin/python3',
- 'import sys',
- 'sys.stderr.write("stderr stuff")',
- "print('%s')" % json.dumps(module_result)
--- a/bin/ansible-test
+++ b/bin/ansible-test
@@ -1,4 +1,4 @@
diff --git a/debian/patches/0009-resolvelib_compat.patch b/debian/patches/0009-resolvelib_compat.patch
deleted file mode 100644
index 7a633cd..0000000
--- a/debian/patches/0009-resolvelib_compat.patch
+++ /dev/null
@@ -1,113 +0,0 @@
-Description: ansible-galaxy - support resolvelib >= 0.5.3, < 1.1.0
-Author: Wong Hoi Sing Edison <hswong3i@gmail.com>
-Origin: upstream, https://github.com/ansible/ansible/pull/80196
-Applied-Upstream: yes
-Forwarded: not-needed
-Reviewed-by: Lee Garrett <debian@rocketjump.eu>
-Last-Update: 2023-10-23
----
-This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
---- /dev/null
-+++ b/changelogs/fragments/79399-resolvelib_lt_0_10_0.yml
-@@ -0,0 +1,2 @@
-+minor_changes:
-+ - ansible-galaxy - support ``resolvelib >= 0.5.3, < 1.1.0``.
---- a/lib/ansible/galaxy/dependency_resolution/providers.py
-+++ b/lib/ansible/galaxy/dependency_resolution/providers.py
-@@ -40,7 +40,7 @@
-
- # TODO: add python requirements to ansible-test's ansible-core distribution info and remove the hardcoded lowerbound/upperbound fallback
- RESOLVELIB_LOWERBOUND = SemanticVersion("0.5.3")
--RESOLVELIB_UPPERBOUND = SemanticVersion("0.9.0")
-+RESOLVELIB_UPPERBOUND = SemanticVersion("1.1.0")
- RESOLVELIB_VERSION = SemanticVersion.from_loose_version(LooseVersion(resolvelib_version))
-
-
-@@ -190,7 +190,7 @@
- Mapping of identifier, list of named tuple pairs.
- The named tuples have the entries ``requirement`` and ``parent``.
-
-- resolvelib >=0.8.0, <= 0.8.1
-+ resolvelib >=0.8.0, <= 1.0.1
-
- :param identifier: The value returned by ``identify()``.
-
---- a/requirements.txt
-+++ b/requirements.txt
-@@ -12,4 +12,4 @@
- # NOTE: Ref: https://github.com/sarugaku/resolvelib/issues/69
- # NOTE: When updating the upper bound, also update the latest version used
- # NOTE: in the ansible-galaxy-collection test suite.
--resolvelib >= 0.5.3, < 0.9.0 # dependency resolver used by ansible-galaxy
-+resolvelib >= 0.5.3, < 1.1.0 # dependency resolver used by ansible-galaxy
---- a/test/lib/ansible_test/_data/requirements/ansible.txt
-+++ b/test/lib/ansible_test/_data/requirements/ansible.txt
-@@ -12,4 +12,4 @@
- # NOTE: Ref: https://github.com/sarugaku/resolvelib/issues/69
- # NOTE: When updating the upper bound, also update the latest version used
- # NOTE: in the ansible-galaxy-collection test suite.
--resolvelib >= 0.5.3, < 0.9.0 # dependency resolver used by ansible-galaxy
-+resolvelib >= 0.5.3, < 1.1.0 # dependency resolver used by ansible-galaxy
---- a/test/sanity/code-smell/package-data.requirements.in
-+++ b/test/sanity/code-smell/package-data.requirements.in
-@@ -2,7 +2,7 @@
- wheel # required to build wheel
- jinja2
- pyyaml # ansible-core requirement
--resolvelib < 0.9.0
-+resolvelib < 1.1.0
- rstcheck < 4 # match version used in other sanity tests
- antsibull-changelog
- setuptools == 45.2.0 # minimum supported setuptools
---- a/test/sanity/code-smell/package-data.requirements.txt
-+++ b/test/sanity/code-smell/package-data.requirements.txt
-@@ -10,7 +10,7 @@
- pyproject_hooks==1.0.0
- pyparsing==3.0.9
- PyYAML==6.0
--resolvelib==0.8.1
-+resolvelib==1.0.1
- rstcheck==3.5.0
- semantic-version==2.10.0
- setuptools==45.2.0
---- a/lib/ansible_core.egg-info/requires.txt
-+++ b/lib/ansible_core.egg-info/requires.txt
-@@ -2,4 +2,4 @@
- PyYAML>=5.1
- cryptography
- packaging
--resolvelib<0.9.0,>=0.5.3
-+resolvelib<1.1.0,>=0.5.3
---- a/test/integration/targets/ansible-galaxy-collection/vars/main.yml
-+++ b/test/integration/targets/ansible-galaxy-collection/vars/main.yml
-@@ -9,6 +9,8 @@
- - "0.6.0"
- - "0.7.0"
- - "0.8.0"
-+ - "0.9.0"
-+ - "1.0.1"
-
- unsupported_resolvelib_versions:
- - "0.2.0" # Fails on import
---- a/PKG-INFO
-+++ b/PKG-INFO
-@@ -35,7 +35,7 @@
- Requires-Dist: PyYAML>=5.1
- Requires-Dist: cryptography
- Requires-Dist: packaging
--Requires-Dist: resolvelib<0.9.0,>=0.5.3
-+Requires-Dist: resolvelib<1.1.0,>=0.5.3
-
- [![PyPI version](https://img.shields.io/pypi/v/ansible-core.svg)](https://pypi.org/project/ansible-core)
- [![Docs badge](https://img.shields.io/badge/docs-latest-brightgreen.svg)](https://docs.ansible.com/ansible/latest/)
---- a/lib/ansible_core.egg-info/PKG-INFO
-+++ b/lib/ansible_core.egg-info/PKG-INFO
-@@ -35,7 +35,7 @@
- Requires-Dist: PyYAML>=5.1
- Requires-Dist: cryptography
- Requires-Dist: packaging
--Requires-Dist: resolvelib<0.9.0,>=0.5.3
-+Requires-Dist: resolvelib<1.1.0,>=0.5.3
-
- [![PyPI version](https://img.shields.io/pypi/v/ansible-core.svg)](https://pypi.org/project/ansible-core)
- [![Docs badge](https://img.shields.io/badge/docs-latest-brightgreen.svg)](https://docs.ansible.com/ansible/latest/)
diff --git a/debian/patches/0010-fix-facter.patch b/debian/patches/0010-fix-facter.patch
deleted file mode 100644
index 943c2f6..0000000
--- a/debian/patches/0010-fix-facter.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-Description: Fix facter when installed without puppet
-Author: Brian Coca <brian.coca+git@gmail.com>
-Origin: upstream, https://github.com/ansible/ansible/pull/80645/
-Bug: https://github.com/ansible/ansible/issues/80496
-Forwarded: not-needed
-Reviewed-by: Lee Garrett <debian@rocketjump.eu>
-Last-Update: 2023-11-10
----
-This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
-diff --git a/changelogs/fragments/setup_facter_fix.yml b/changelogs/fragments/setup_facter_fix.yml
-new file mode 100644
-index 00000000000000..78a6b005a4abf2
---- /dev/null
-+++ b/changelogs/fragments/setup_facter_fix.yml
-@@ -0,0 +1,2 @@
-+bugfixes:
-+ - setup module (fact gathering) will now try to be smarter about different versions of facter emitting error when --puppet flag is used w/o puppet.
-diff --git a/lib/ansible/module_utils/facts/other/facter.py b/lib/ansible/module_utils/facts/other/facter.py
-index 3f83999d419d5c..9b6edc0b5ceaf9 100644
---- a/lib/ansible/module_utils/facts/other/facter.py
-+++ b/lib/ansible/module_utils/facts/other/facter.py
-@@ -1,27 +1,12 @@
--# This file is part of Ansible
--#
--# Ansible is free software: you can redistribute it and/or modify
--# it under the terms of the GNU General Public License as published by
--# the Free Software Foundation, either version 3 of the License, or
--# (at your option) any later version.
--#
--# Ansible is distributed in the hope that it will be useful,
--# but WITHOUT ANY WARRANTY; without even the implied warranty of
--# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
--# GNU General Public License for more details.
--#
--# You should have received a copy of the GNU General Public License
--# along with Ansible. If not, see <http://www.gnu.org/licenses/>.
-+# Copyright (c) 2023 Ansible Project
-+# GNU General Public License v3.0+ (see COPYING or https://www.gnu.org/licenses/gpl-3.0.txt)
-
- from __future__ import (absolute_import, division, print_function)
- __metaclass__ = type
-
- import json
-
--import ansible.module_utils.compat.typing as t
--
- from ansible.module_utils.facts.namespace import PrefixFactNamespace
--
- from ansible.module_utils.facts.collector import BaseFactCollector
-
-
-@@ -49,6 +34,12 @@ def run_facter(self, module, facter_path):
- # if facter is installed, and we can use --json because
- # ruby-json is ALSO installed, include facter data in the JSON
- rc, out, err = module.run_command(facter_path + " --puppet --json")
-+
-+ # for some versions of facter, --puppet returns an error if puppet is not present,
-+ # try again w/o it, other errors should still appear and be sent back
-+ if rc != 0:
-+ rc, out, err = module.run_command(facter_path + " --json")
-+
- return rc, out, err
-
- def get_facter_output(self, module):
-
-From dace8abd19b1ef17d6534d881234e4771263dd1b Mon Sep 17 00:00:00 2001
-From: Brian Coca <brian.coca+git@gmail.com>
-Date: Wed, 26 Apr 2023 12:30:08 -0400
-Subject: [PATCH 2/2] restore import
-
----
- lib/ansible/module_utils/facts/other/facter.py | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/lib/ansible/module_utils/facts/other/facter.py b/lib/ansible/module_utils/facts/other/facter.py
-index 9b6edc0b5ceaf9..063065251dd36e 100644
---- a/lib/ansible/module_utils/facts/other/facter.py
-+++ b/lib/ansible/module_utils/facts/other/facter.py
-@@ -6,6 +6,8 @@
-
- import json
-
-+import ansible.module_utils.compat.typing as t
-+
- from ansible.module_utils.facts.namespace import PrefixFactNamespace
- from ansible.module_utils.facts.collector import BaseFactCollector
-
diff --git a/debian/patches/series b/debian/patches/series
index 340d630..66bfa3f 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1 @@
0005-use-py3.patch
-0009-resolvelib_compat.patch
-0010-fix-facter.patch
diff --git a/debian/watch b/debian/watch
index e98fc57..ae1cc69 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,4 +1,4 @@
version=4
opts=dversionmangle=s/\+dfsg//,repacksuffix=+dfsg \
-https://pypi.debian.net/ansible-core/ ansible-core-(2\.14\.[0-9]+).tar.gz
+https://pypi.debian.net/ansible-core/ ansible-core-([0-9]+\.[0-9]+\.[0-9]+).tar.gz