summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 05:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 05:32:43 +0000
commitdeee2a8dbc51c7cd3a5aa10ee560589932c03dc6 (patch)
treebd5cc2ccc9c643e69c49ce75e70612710db84ac1
parentReleasing progress-linux version 2:2.7.2-1~progress7.99u1. (diff)
downloadcryptsetup-deee2a8dbc51c7cd3a5aa10ee560589932c03dc6.tar.xz
cryptsetup-deee2a8dbc51c7cd3a5aa10ee560589932c03dc6.zip
Merging debian version 2:2.7.2-2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog10
-rw-r--r--debian/control4
-rwxr-xr-xdebian/tests/utils/mkinitramfs3
3 files changed, 13 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 87907de..bf00e7a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+cryptsetup (2:2.7.2-2) unstable; urgency=medium
+
+ * Update standards version to 4.7.0, no changes needed.
+ * d/crontrol: cryptsetup-initramfs: Add Breaks: libcryptsetup12 (<<
+ 2:2.7.2-1) since the hook assumes libcryptsetup.so.12 is not linked with
+ libargon2.so. (Closes: #1068849)
+ * d/t/utils/mkinitramfs: Remove obsolete copy_libgcc() call.
+
+ -- Guilhem Moulin <guilhem@debian.org> Mon, 15 Apr 2024 00:51:12 +0200
+
cryptsetup (2:2.7.2-1~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-updates, remaining changes:
diff --git a/debian/control b/debian/control
index a6063c6..d10f4f6 100644
--- a/debian/control
+++ b/debian/control
@@ -34,7 +34,7 @@ Build-Depends: asciidoctor <!nodoc>,
uuid-dev,
xsltproc <!nodoc>,
xxd <!nocheck>
-Standards-Version: 4.6.2
+Standards-Version: 4.7.0
Homepage: https://gitlab.com/cryptsetup/cryptsetup
Vcs-Browser: https://git.progress-linux.org/packages/graograman-backports/cryptsetup
Vcs-Git: https://git.progress-linux.org/packages/graograman-backports/cryptsetup
@@ -104,7 +104,7 @@ Depends: busybox | busybox-static,
initramfs-tools (>= 0.137) | linux-initramfs-tool,
${misc:Depends}
Recommends: console-setup, kbd
-Breaks: cryptsetup (<< 2:2.0.3-1)
+Breaks: cryptsetup (<< 2:2.0.3-1), libcryptsetup12 (<< 2:2.7.2-1)
Replaces: cryptsetup (<< 2:2.0.3-1)
Conflicts: lvm2 (<< 2.03.15-1)
Description: disk encryption support - initramfs integration
diff --git a/debian/tests/utils/mkinitramfs b/debian/tests/utils/mkinitramfs
index 6bc70f4..d66ed75 100755
--- a/debian/tests/utils/mkinitramfs
+++ b/debian/tests/utils/mkinitramfs
@@ -109,10 +109,9 @@ copy_exec /sbin/dmsetup
copy_exec /usr/bin/dpkg-deb
copy_exec /bin/tar
-# assume ossl-modules/legacy.so and libgcc_s.so are relative to the linked libcryptsetup.so
+# assume ossl-modules/legacy.so is relative to the linked libcryptsetup.so
libdir="$(env --unset=LD_PRELOAD ldd /sbin/cryptsetup | sed -nr '/.*=>\s*(\S+)\/libcryptsetup\.so\..*/ {s//\1/p;q}')"
copy_exec "$libdir/ossl-modules/legacy.so" || true
-copy_libgcc "$libdir"
for p in /sbin/cryptsetup /sbin/lvm /sbin/mdadm /sbin/mke2fs /sbin/mkfs.btrfs /bin/btrfs; do
if [ -x "$p" ]; then