summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 20:15:19 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 20:15:19 +0000
commit00bfb985b9becadfdd13d840cd44bc26dce4c8d1 (patch)
tree21cd33b2b68b96edf9ab03656f20a788b3049241
parentMerging upstream version 0.1.24. (diff)
downloaddebputy-00bfb985b9becadfdd13d840cd44bc26dce4c8d1.tar.xz
debputy-00bfb985b9becadfdd13d840cd44bc26dce4c8d1.zip
Merging debian version 0.1.24.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog37
-rwxr-xr-xdebian/tests/debputy-cli-lint-lsp1
2 files changed, 36 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 8ba4b82..4a6bb84 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,36 @@
+debputy (0.1.24) unstable; urgency=medium
+
+ * Manifest:
+ - Add new keyword `services` under `packages.foo`, where the
+ packager can specify whether a given service or (systemd) unit
+ should be enabled/started on installation and how upgrades
+ should be managed. With this, more packages using
+ `dh_installsystemd` and `dh_installinit` can hopefully now use
+ `debputy`. Note user services is mentioned in the manifest
+ feature, but `debputy` does not actually detect any user
+ services.
+
+ * Plugin API:
+ - Detect duplicate service registrations and error out when
+ detected. The API is private, so it will not affect any
+ plugins outside `debputy`.
+
+ * debputy: Service maintscript snippets are now run in "service" order
+ * autopkgtests: Run `debputy lint` with the linter exit code
+ * debputy: Fix crash on re-encoding compressed manpages.
+ Thanks to Andrey Rakhmatullin <wrar@debian.org> (Closes: #1068102)
+ * debputy: Fix bug in -dbgsym generation that triggered lintian warnings.
+ Thanks to Chris Hofstaedtler <zeha@debian.org> (Closes: debputy#80)
+ * debputy: Fix crash bug on showing a pluggable-manifest-rule with
+ certain mutual exclusive attributes
+ * debputy: Fix `plugin show p-m-r` to show mutual exclusive optional attributes
+ * debputy: Avoid using `try-restart` as `deb-systemd-invoke` does not
+ support it. Replace it with regular `restart`.
+ * The getting started guide now features a section on migrating
+ `dh_installsystemd` and `dh_installinit` overrides.
+
+ -- Niels Thykier <niels@thykier.net> Sun, 31 Mar 2024 17:31:02 +0200
+
debputy (0.1.23-0.0~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
@@ -15,7 +48,7 @@ debputy (0.1.23) unstable; urgency=medium
* Breaking: Migration mode to `dh-sequence-zz-debputy-rrr`
should have included `dh_shlibdeps`, but did not due to a
- mistake. This broke automatic substvar suport and has been
+ mistake. This broke automatic substvar support and has been
retroactively fixed. Likewise, `debputy migrate-from-dh` has
been updated to detect hook targets for `dh_shlibdeps`.
@@ -44,7 +77,7 @@ debputy (0.1.22.3) unstable; urgency=medium
package names.
* debputy: Enable `lint` to run with invalid `debian/control` file.
As example, if a package stanza is missing the `Architecture`
- field or is syntaxically invalid, then the linter will now still
+ field or is syntactically invalid, then the linter will now still
run and report this linting errors (rather than `debputy` hard
stopping on the first issue).
diff --git a/debian/tests/debputy-cli-lint-lsp b/debian/tests/debputy-cli-lint-lsp
index c808abe..1385d8e 100755
--- a/debian/tests/debputy-cli-lint-lsp
+++ b/debian/tests/debputy-cli-lint-lsp
@@ -1,6 +1,7 @@
#!/bin/sh
set -e -u -x
+debputy lint --linter-exit-code
debputy lint --no-linter-exit-code
debputy lsp editor-config emacs
debputy lsp editor-config vim