summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 20:16:54 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 20:16:54 +0000
commit0ad5a5f4a66df9cff7778cb43a83f584f3340e27 (patch)
tree490d9d63eea149815dee1e22a4a2251264706016
parentMerging upstream version 0.1.25. (diff)
downloaddebputy-0ad5a5f4a66df9cff7778cb43a83f584f3340e27.tar.xz
debputy-0ad5a5f4a66df9cff7778cb43a83f584f3340e27.zip
Merging debian version 0.1.25.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog32
-rw-r--r--debian/control9
-rw-r--r--debian/copyright27
-rw-r--r--debian/salsa-ci.yml20
-rw-r--r--debian/source/lintian-overrides5
-rwxr-xr-xdebian/tests/debputy-cli-lint-lsp2
6 files changed, 80 insertions, 15 deletions
diff --git a/debian/changelog b/debian/changelog
index c2b8c59..ee40e8b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,35 @@
+debputy (0.1.25) unstable; urgency=medium
+
+ * LSP/lint:
+ - Provide initial hover docs for `d/debputy.manifest`.
+ - Provide initial completion support for `d/debputy.manifest`.
+ - Provide more diagnostics for `d/debputy.manifest`. Note that
+ `debputy check-manifest` still covers a lot more, but it usually
+ only reports one issue at the time and does not work with the LSP.
+ - When the editor does not provide a language id for the files,
+ `debputy` now attempts to guess the language from the filename.
+ This makes the language server work with most editors that do
+ not know about the file format (such as `debian/debputy.manifest`).
+
+ [ Niels Thykier ]
+ * d/copyright: Dual license linter and LSP, since that makes it easier
+ to share code with `debpkg-metadata`.
+ * debputy: Add YAML mode (debputy.manifest) to emacs LSP editor config
+ example.
+ * LSP/lint: Fix crash bug with some errors in debputy.manifest
+ * Migrate to `python3-ruyaml` as default. It has fewer arch:any
+ dependencies, which in turn should make arch bootstrapping easier.
+ (Closes: debputy#84)
+ * debputy: Make `debputy lsp editor-config` list known config names.
+ Thanks to David Kalnischkies <david@kalnischkies.de> (Closes: #82)
+ * LSP: Fallback to filename based detection if no language id is provided
+
+ [ Otto Kekäläinen ]
+ * Add Lintian overrides
+ * Add Salsa-CI to both build packages, and to run `debputy lint` on itself
+
+ -- Niels Thykier <niels@thykier.net> Thu, 04 Apr 2024 07:18:03 +0200
+
debputy (0.1.24-0.0~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/control b/debian/control
index 57561a8..cd43a73 100644
--- a/debian/control
+++ b/debian/control
@@ -15,8 +15,9 @@ Build-Depends: debhelper-compat (= 13),
python3-debian,
python3-hunspell <!nocheck>,
python3-lsprotocol <!nocheck>,
+ python3-pygls <!nocheck !pkg.debputy.minimal-tests>,
python3-pytest <!nocheck>,
- python3-ruamel.yaml,
+ python3-ruyaml,
# debputy-plugin-foo,
# The code was never checked with an older version than 3.11...
python3:any (>= 3.11~),
@@ -33,8 +34,6 @@ Package: dh-debputy
Architecture: all
Depends: debhelper,
man-db <!pkg.debputy.minimal>,
-# The code was never checked with an older version than 3.11...
- python3:any (>= 3.11~),
# The colors dependencies are not necessary for debputy to work.
# However, to have coloring work, we need to use Depends because
# Recommends/Suggests are not resolved for builds and this should
@@ -42,7 +41,9 @@ Depends: debhelper,
python3-colored <!pkg.debputy.no-color>,
python3-colorlog <!pkg.debputy.no-color>,
python3-debian,
- python3-ruamel.yaml,
+ python3-ruyaml,
+# The code was never checked with an older version than 3.11...
+ python3:any (>= 3.11~),
strip-nondeterminism,
Recommends: python3-argcomplete,
Suggests: hunspell-en-us,
diff --git a/debian/copyright b/debian/copyright
index 7523343..5c3c99a 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -9,6 +9,22 @@ Copyright: 2022 Niels Thykier <niels@thykier.net>
2022 Chris Hofstaedtler <zeha@debian.org>
License: GPL-2+
+Files: tests/*
+Copyright: 2022 Niels Thykier <niels@thykier.net>
+ 2022 Chris Hofstaedtler <zeha@debian.org>
+License: GPL-2+
+
+Files: dh_debputy
+Copyright: 1997-2011 Joey Hess <joeyh@debian.org>
+ 2015-2022 Niels Thykier <niels@thykier.net>
+Comment: It is 95% copy-paste of dh_builddeb
+License: GPL-2+
+
+Files: src/debputy/lsp/* src/debputy/linting/*
+Copyright: 2022 Niels Thykier <niels@thykier.net>
+Comment: Dual-licensed with the intention that parts can be moved to debpkg-metadata.
+License: GPL-2+ or Apache-2.0
+
Files: src/debputy/lsp/text_edit.py
Copyright: Copyright 2017-2020 Palantir Technologies, Inc.
Copyright 2021- Python Language Server Contributors.
@@ -30,17 +46,6 @@ License: Expat
CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE
OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-Files: tests/*
-Copyright: 2022 Niels Thykier <niels@thykier.net>
- 2022 Chris Hofstaedtler <zeha@debian.org>
-License: GPL-2+
-
-Files: dh_debputy
-Copyright: 1997-2011 Joey Hess <joeyh@debian.org>
- 2015-2022 Niels Thykier <niels@thykier.net>
-Comment: It is 95% copy-paste of dh_builddeb
-License: GPL-2+
-
Files: src/debputy/lsp/vendoring/_deb822_repro/*
Copyright:
2021 Niels Thykier <niels@thykier.net>
diff --git a/debian/salsa-ci.yml b/debian/salsa-ci.yml
new file mode 100644
index 0000000..49376b1
--- /dev/null
+++ b/debian/salsa-ci.yml
@@ -0,0 +1,20 @@
+---
+include:
+ - https://salsa.debian.org/salsa-ci-team/pipeline/raw/master/salsa-ci.yml
+ - https://salsa.debian.org/salsa-ci-team/pipeline/raw/master/pipeline-jobs.yml
+
+variables:
+ SALSA_CI_DISABLE_WRAP_AND_SORT: 0
+ SALSA_CI_WRAP_AND_SORT_ARGS: '-abkt'
+ SALSA_CI_AUTOPKGTEST_ALLOWED_EXIT_STATUS: 0
+ SALSA_CI_DISABLE_APTLY: 0
+
+debputy-lint:
+ stage: provisioning
+ image: debian:sid-slim
+ script:
+ - apt-get update -qq && apt-get -qq install --no-install-recommends --yes dh-debputy python3-pygls
+ - PERL5LIB=lib debputy lint --spellcheck
+ except:
+ variables:
+ - $CI_COMMIT_TAG != null && $SALSA_CI_ENABLE_PIPELINE_ON_TAGS !~ /^(1|yes|true)$/
diff --git a/debian/source/lintian-overrides b/debian/source/lintian-overrides
new file mode 100644
index 0000000..43506f5
--- /dev/null
+++ b/debian/source/lintian-overrides
@@ -0,0 +1,5 @@
+# https://salsa.debian.org/debian/debputy/-/issues/77
+missing-build-dependency-for-dh-addon debputy (does not satisfy dh-debputy:any) [debian/rules]
+missing-build-dependency-for-dh_-command dh_debputy (does not satisfy dh-debputy:any) [debian/rules]
+# https://bugs.debian.org/1067653 substvar hints are no longer universally applicable
+debhelper-but-no-misc-depends dh-debputy
diff --git a/debian/tests/debputy-cli-lint-lsp b/debian/tests/debputy-cli-lint-lsp
index 1385d8e..91f014e 100755
--- a/debian/tests/debputy-cli-lint-lsp
+++ b/debian/tests/debputy-cli-lint-lsp
@@ -3,5 +3,7 @@ set -e -u -x
debputy lint --linter-exit-code
debputy lint --no-linter-exit-code
+debputy lsp editor-config
debputy lsp editor-config emacs
+debputy lsp editor-config emacs+eglot
debputy lsp editor-config vim