summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 20:18:23 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 20:18:23 +0000
commit9a3939a0ac53fe5d422ac1de0286bcaee72d77e6 (patch)
treef43f75433d005e83d81ea2ca78a6927b00514b8d
parentMerging upstream version 0.1.28. (diff)
downloaddebputy-9a3939a0ac53fe5d422ac1de0286bcaee72d77e6.tar.xz
debputy-9a3939a0ac53fe5d422ac1de0286bcaee72d77e6.zip
Merging debian version 0.1.28.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog28
-rw-r--r--debian/control3
-rw-r--r--debian/copyright10
-rw-r--r--debian/tests/control6
-rwxr-xr-xdebian/tests/debputy-cli-lsp5
5 files changed, 50 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 6dcd582..0c4f679 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,31 @@
+debputy (0.1.28) unstable; urgency=medium
+
+ [ Niels Thykier ]
+ * LSP/Lint:
+ - Fix missing `binary-targets` value for R³
+ - Emit multiple issues for the same value if applicable in deb822 files
+ - Detect exclusive values used with other values in deb822 files. Examples
+ include `any` or `all` in the `Architecture` field.
+ - Add `hover` docs to `debian/copyright` fields.
+ - Add basic support for cross-file data reference. As an example,
+ the `debputy.manifest` code can now determine which packages are
+ listed in `debian/control`. Additionally, the `debian/changelog` checks
+ will now assert that the source package name in the newest entry match
+ the `Source` field of `debian/control`.
+ - Provide specialized hover docs for `debian/control` that provides
+ specialized help for the synopsis part of the `Description` field.
+ - The hover docs for `debian/control` will now provide hover docs for
+ some substvars.
+
+ * debputy: `lsp features` now reports if general features are missing
+ * d/copyright: Add missing `GPL-2+` and missing `Apache-2` license stanzas
+
+ [ Andrea Pappacoda ]
+ * `debputy lsp editor-configs`: Add `yegappan`'s VIM LSP.
+ (https://github.com/yegappan/lsp).
+
+ -- Niels Thykier <niels@thykier.net> Wed, 10 Apr 2024 13:32:34 +0000
+
debputy (0.1.27.1-0.0~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/control b/debian/control
index b91cea1..9f598aa 100644
--- a/debian/control
+++ b/debian/control
@@ -14,10 +14,11 @@ Build-Depends: debhelper-compat (= 13),
python3-colorlog <!pkg.debputy.minimal>,
python3-debian,
python3-hunspell <!nocheck>,
- python3-levenshtein <pkg.debhelper.ci>,
+ python3-levenshtein <pkg.debputy.ci>,
python3-lsprotocol <!nocheck>,
python3-pygls <!nocheck !pkg.debputy.minimal-tests>,
python3-pytest <!nocheck>,
+ python3-pytest-cov <pkg.debputy.test-coverage>,
python3-ruyaml,
# debputy-plugin-foo,
# The code was never checked with an older version than 3.11...
diff --git a/debian/copyright b/debian/copyright
index 5c3c99a..e9b0cd7 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -21,7 +21,7 @@ Comment: It is 95% copy-paste of dh_builddeb
License: GPL-2+
Files: src/debputy/lsp/* src/debputy/linting/*
-Copyright: 2022 Niels Thykier <niels@thykier.net>
+Copyright: 2024 Niels Thykier <niels@thykier.net>
Comment: Dual-licensed with the intention that parts can be moved to debpkg-metadata.
License: GPL-2+ or Apache-2.0
@@ -52,3 +52,11 @@ Copyright:
License: GPL-2+
Comment: Embedded copy of part of `python-debian` with patches. The patches are pending
review at https://salsa.debian.org/python-debian-team/python-debian/-/merge_requests/130
+
+License: GPL-2+
+ On Debian systems the full text of the GNU General Public License version 2
+ can be found in the `/usr/share/common-licenses/GPL-2' file.
+
+License: Apache-2
+ On Debian systems the full text of the Apache License version 2
+ can be found in the `/usr/share/common-licenses/Apache-2.0' file.
diff --git a/debian/tests/control b/debian/tests/control
index 16f64a6..dfe650c 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -15,3 +15,9 @@ Tests: debputy-cli-lint-lsp
Restrictions: allow-stderr, superficial
Depends: python3-lsprotocol,
@,
+
+Tests: debputy-cli-lsp
+Restrictions: allow-stderr, superficial
+Depends: python3-lsprotocol,
+ python3-pygls,
+ @,
diff --git a/debian/tests/debputy-cli-lsp b/debian/tests/debputy-cli-lsp
new file mode 100755
index 0000000..12b63c0
--- /dev/null
+++ b/debian/tests/debputy-cli-lsp
@@ -0,0 +1,5 @@
+#!/bin/sh
+set -e -u -x
+
+debputy lsp features
+debputy lsp server </dev/null