summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 01:05:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 01:05:49 +0000
commita8c60485caa50df9e31f90e4064093a65df03edf (patch)
treea72b77613841a5e33a50ec1bc42dee2ebe65715a
parentMerging upstream version 0.1.30. (diff)
downloaddebputy-a8c60485caa50df9e31f90e4064093a65df03edf.tar.xz
debputy-a8c60485caa50df9e31f90e4064093a65df03edf.zip
Merging debian version 0.1.30.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog34
-rw-r--r--debian/control81
-rw-r--r--debian/copyright19
-rw-r--r--debian/tests/control53
-rwxr-xr-xdebian/tests/debputy-cli-lint-lsp1
5 files changed, 132 insertions, 56 deletions
diff --git a/debian/changelog b/debian/changelog
index c1fe3ab..dc812cd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,37 @@
+debputy (0.1.30) unstable; urgency=medium
+
+ * LSP/Lint:
+ - Detect duplicate separators (commas) in most fields
+ - Fix typo in hover doc for `DM-Upload-Allowed`
+ - Support `X-Style: black` as style declaration to activate
+ automatic reformatting support. Conceptually, this is similar
+ to `wrap-and-sort -satkb` but it may evolve over time.
+ - Support reformatting of field contents on save or via explicit
+ reformat document request from editor (requires that `debputy`
+ knows which style you want - see previous entry for how to do
+ a per-package rule).
+ - Update `emacs+eglot` editor config snippet after the latest
+ elpa-dpkg-dev-el upload.
+
+ * Fix crash bug in embedded python3-debian code
+ * Declare styles for:
+ - Niels Thykier (black)
+ - Chris Hofstaedtler (black)
+
+ * style-prefs.yaml: Adding format rules for several packages
+ * Apply `debian black` style to `d/tests/control`
+ * Fix duplicate stderr logger with LSP (and similar commands)
+ * Fix invalid assertion error in some packages (Closes: #1069362)
+ * Cope better with `python3-colored (<< 2)`
+ Thanks to Chris Hofstaedtler <zeha@debian.org>
+ * Provide a new reformat subcommand. It works like `debputy lint`, but
+ only does formatting (which `debputy lint` does none of).
+ * debputy lint: Fix crash bug on missing `Source` field in `d/control`
+ * debputy: Make `lint` and `check-manifest' quieter to support
+ `pre-commit` hook
+
+ -- Niels Thykier <niels@thykier.net> Sun, 28 Apr 2024 13:21:45 +0000
+
debputy (0.1.29-0.0~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/control b/debian/control
index 9f598aa..f8eceb7 100644
--- a/debian/control
+++ b/debian/control
@@ -4,27 +4,30 @@ Priority: optional
Maintainer: Progress Linux Maintainers <maintainers@lists.progress-linux.org>
XSBC-Uploaders: Daniel Baumann <daniel.baumann@progress-linux.org>
XSBC-Original-Maintainer: Debputy Maintainers <debputy@packages.debian.org>
-XSBC-Original-Uploaders: Niels Thykier <niels@thykier.net>,
+XSBC-Original-Uploaders:
+ Niels Thykier <niels@thykier.net>,
Bugs: mailto:maintainers@lists.progress-linux.org
-Build-Depends: debhelper-compat (= 13),
+Build-Depends:
+ debhelper-compat (= 13),
# man-db <pkg.debputy.ci>,
- dh-sequence-single-binary,
- hunspell-en-us <!nocheck>,
- python3-colored <!pkg.debputy.minimal>,
- python3-colorlog <!pkg.debputy.minimal>,
- python3-debian,
- python3-hunspell <!nocheck>,
- python3-levenshtein <pkg.debputy.ci>,
- python3-lsprotocol <!nocheck>,
- python3-pygls <!nocheck !pkg.debputy.minimal-tests>,
- python3-pytest <!nocheck>,
- python3-pytest-cov <pkg.debputy.test-coverage>,
- python3-ruyaml,
+ dh-sequence-single-binary,
+ hunspell-en-us <!nocheck>,
+ python3-colored <!pkg.debputy.minimal>,
+ python3-colorlog <!pkg.debputy.minimal>,
+ python3-debian,
+ python3-hunspell <!nocheck>,
+ python3-levenshtein <pkg.debputy.ci>,
+ python3-lsprotocol <!nocheck>,
+ python3-pygls <!nocheck !pkg.debputy.minimal-tests>,
+ python3-pytest <!nocheck>,
+ python3-pytest-cov <pkg.debputy.test-coverage>,
+ python3-ruyaml,
# debputy-plugin-foo,
# The code was never checked with an older version than 3.11...
- python3:any (>= 3.11~),
- strip-nondeterminism <!nocheck>,
+ python3:any (>= 3.11~),
+ strip-nondeterminism <!nocheck>,
Rules-Requires-Root: no
+X-Style: black
Standards-Version: 4.6.2
Homepage: https://salsa.debian.org/debian/debputy
Vcs-Browser: https://git.progress-linux.org/packages/graograman-backports/debputy
@@ -34,32 +37,36 @@ XSBC-Original-Vcs-Git: https://salsa.debian.org/debian/debputy.git
Package: dh-debputy
Architecture: all
-Depends: debhelper,
- man-db <!pkg.debputy.minimal>,
+Depends:
+ debhelper,
+ man-db <!pkg.debputy.minimal>,
# The colors dependencies are not necessary for debputy to work.
# However, to have coloring work, we need to use Depends because
# Recommends/Suggests are not resolved for builds and this should
# "just work" for users.
- python3-colored <!pkg.debputy.no-color>,
- python3-colorlog <!pkg.debputy.no-color>,
- python3-debian,
- python3-ruyaml,
+ python3-colored <!pkg.debputy.no-color>,
+ python3-colorlog <!pkg.debputy.no-color>,
+ python3-debian,
+ python3-ruyaml,
# The code was never checked with an older version than 3.11...
- python3:any (>= 3.11~),
- strip-nondeterminism,
-Recommends: python3-argcomplete,
-Suggests: hunspell-en-us,
- python3-hunspell,
- python3-levenshtein,
- python3-lsprotocol,
- python3-pygls,
-Provides: debputy-plugin-gnome,
- debputy-plugin-numpy3,
- debputy-plugin-perl-openssl,
- dh-sequence-debputy (= ${binary:Version}),
- dh-sequence-installdebputy (= ${binary:Version}),
- dh-sequence-zz-debputy (= ${binary:Version}),
- dh-sequence-zz-debputy-rrr (= ${binary:Version}),
+ python3:any (>= 3.11~),
+ strip-nondeterminism,
+Recommends:
+ python3-argcomplete,
+Suggests:
+ hunspell-en-us,
+ python3-hunspell,
+ python3-levenshtein,
+ python3-lsprotocol,
+ python3-pygls,
+Provides:
+ debputy-plugin-gnome,
+ debputy-plugin-numpy3,
+ debputy-plugin-perl-openssl,
+ dh-sequence-debputy (= ${binary:Version}),
+ dh-sequence-installdebputy (= ${binary:Version}),
+ dh-sequence-zz-debputy (= ${binary:Version}),
+ dh-sequence-zz-debputy-rrr (= ${binary:Version}),
Multi-Arch: foreign
Description: Manifest style Debian-based package builder (debhelper integration)
Package builder that provides a declarative manifest for building Debian-based
diff --git a/debian/copyright b/debian/copyright
index f0ff31c..7050d02 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -53,6 +53,12 @@ License: GPL-2+
Comment: Embedded copy of part of `python-debian` with patches. The patches are pending
review at https://salsa.debian.org/python-debian-team/python-debian/-/merge_requests/130
+Files: src/debputy/lsp/vendoring/wrap_and_sort.py
+Copyright: 2008-2018, Benjamin Drung <bdrung@debian.org>
+ 2010-2011, Stefano Rivera <stefanor@ubuntu.com>
+License: ISC
+Comment: Embedded copy of part of `devscripts` with patches to avoid pulling in `devscripts`.
+
License: GPL-2+
On Debian systems the full text of the GNU General Public License version 2
can be found in the `/usr/share/common-licenses/GPL-2' file.
@@ -60,3 +66,16 @@ License: GPL-2+
License: Apache-2
On Debian systems the full text of the Apache License version 2
can be found in the `/usr/share/common-licenses/Apache-2.0' file.
+
+License: ISC
+ Permission to use, copy, modify, and/or distribute this software for any
+ purpose with or without fee is hereby granted, provided that the above
+ copyright notice and this permission notice appear in all copies.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES WITH
+ REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY
+ AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT,
+ INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM
+ LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR
+ OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+ PERFORMANCE OF THIS SOFTWARE.
diff --git a/debian/tests/control b/debian/tests/control
index dfe650c..fba53b8 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -1,23 +1,38 @@
-Tests: debputy-py.test
-Restrictions: allow-stderr
+Tests:
+ debputy-py.test,
+Restrictions:
+ allow-stderr,
# debputy loads the libcap2 library directly for one of the tests
-Depends: libcap2,
- python3-all,
- python3-lsprotocol,
- python3-pytest,
- @,
+Depends:
+ libcap2,
+ python3-all,
+ python3-lsprotocol,
+ python3-pytest,
+ @,
-Tests: debputy-cli
-Restrictions: allow-stderr, superficial
-Depends: @,
+Tests:
+ debputy-cli,
+Restrictions:
+ allow-stderr,
+ superficial,
+Depends:
+ @,
-Tests: debputy-cli-lint-lsp
-Restrictions: allow-stderr, superficial
-Depends: python3-lsprotocol,
- @,
+Tests:
+ debputy-cli-lint-lsp,
+Restrictions:
+ allow-stderr,
+ superficial,
+Depends:
+ python3-lsprotocol,
+ @,
-Tests: debputy-cli-lsp
-Restrictions: allow-stderr, superficial
-Depends: python3-lsprotocol,
- python3-pygls,
- @,
+Tests:
+ debputy-cli-lsp,
+Restrictions:
+ allow-stderr,
+ superficial,
+Depends:
+ python3-lsprotocol,
+ python3-pygls,
+ @,
diff --git a/debian/tests/debputy-cli-lint-lsp b/debian/tests/debputy-cli-lint-lsp
index 91f014e..0c5da22 100755
--- a/debian/tests/debputy-cli-lint-lsp
+++ b/debian/tests/debputy-cli-lint-lsp
@@ -3,6 +3,7 @@ set -e -u -x
debputy lint --linter-exit-code
debputy lint --no-linter-exit-code
+debputy reformat --no-linter-exit-code --no-auto-fix
debputy lsp editor-config
debputy lsp editor-config emacs
debputy lsp editor-config emacs+eglot