summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 21:12:46 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 21:12:46 +0000
commitd0ec168ba250db478389d739013fd331739f1fd0 (patch)
tree66e07a19ff5061d2d9a582d315e5764ded32277c
parentReleasing progress-linux version 1.8.3-2~progress7.99u1. (diff)
downloaddnsdist-d0ec168ba250db478389d739013fd331739f1fd0.tar.xz
dnsdist-d0ec168ba250db478389d739013fd331739f1fd0.zip
Merging debian version 1.8.3-3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules3
-rw-r--r--debian/vendor-h2o/deps/picohttpparser/picohttpparser.c1
-rw-r--r--debian/vendor-h2o/deps/picohttpparser/picohttpparser.h1
5 files changed, 9 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 4bf15c8..1a87829 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+dnsdist (1.8.3-3) unstable; urgency=medium
+
+ * Reenable build on 32bit archs, supporting time_t-64bit
+ * d/rules: tidy up
+ * vendor-h2o: drop $Id$ marker
+
+ -- Chris Hofstaedtler <zeha@debian.org> Tue, 02 Apr 2024 11:07:14 +0200
+
dnsdist (1.8.3-2~progress7.99u1) graograman-backports; urgency=medium
* Initial reupload to graograman-backports.
diff --git a/debian/control b/debian/control
index 0c1ac5f..9180fbc 100644
--- a/debian/control
+++ b/debian/control
@@ -9,9 +9,9 @@ XSBC-Original-Uploaders:
Chris Hofstaedtler <zeha@debian.org>
Bugs: mailto:maintainers@lists.progress-linux.org
Build-Depends:
- architecture-is-64-bit,
cmake,
debhelper-compat (= 13),
+ dpkg-dev (>= 1.22.5),
libboost-all-dev,
libcap-dev [linux-any],
libcdb-dev,
diff --git a/debian/rules b/debian/rules
index 3c6f475..4dcdbbd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -29,8 +29,6 @@ vendored_libh2o:
(cd $(H2O_BUILD_DIR) && CFLAGS='-fPIC' cmake -DWITH_PICOTLS=off -DWITH_BUNDLED_SSL=off -DWITH_MRUBY=off -DCMAKE_INSTALL_PREFIX=/usr $(H2O_SOURCE_DIR))
$(MAKE) -C $(H2O_BUILD_DIR) install DESTDIR=$(H2O_INSTALL_DIR)
-#LDFLAGS += -lh2o-evloop
-
override_dh_auto_configure: vendored_libh2o
# Actually configure dnsdist now
chmod a+x debian/configure-helpers/*
@@ -60,7 +58,6 @@ override_dh_auto_configure: vendored_libh2o
override_dh_auto_build-arch:
dh_auto_build -- V=1
-
override_dh_auto_test:
echo tests disabled, require working ipv4 stack
diff --git a/debian/vendor-h2o/deps/picohttpparser/picohttpparser.c b/debian/vendor-h2o/deps/picohttpparser/picohttpparser.c
index 6a2d872..74463b5 100644
--- a/debian/vendor-h2o/deps/picohttpparser/picohttpparser.c
+++ b/debian/vendor-h2o/deps/picohttpparser/picohttpparser.c
@@ -36,7 +36,6 @@
#endif
#include "picohttpparser.h"
-/* $Id: a707070d11d499609f99d09f97535642cec910a8 $ */
#if __GNUC__ >= 3
#define likely(x) __builtin_expect(!!(x), 1)
diff --git a/debian/vendor-h2o/deps/picohttpparser/picohttpparser.h b/debian/vendor-h2o/deps/picohttpparser/picohttpparser.h
index a8fad71..bf6de7e 100644
--- a/debian/vendor-h2o/deps/picohttpparser/picohttpparser.h
+++ b/debian/vendor-h2o/deps/picohttpparser/picohttpparser.h
@@ -33,7 +33,6 @@
#define ssize_t intptr_t
#endif
-/* $Id: 67fd3ee74103ada60258d8a16e868f483abcca87 $ */
#ifdef __cplusplus
extern "C" {