summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 19:27:12 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 19:27:12 +0000
commitc7fb5f46f59f862b4d282af61e3bf413e706b3ad (patch)
tree4667310370b8745ed00af27fa87a51fb3d0407e7
parentMerging upstream version 1.22.2. (diff)
downloadgolang-1.22-c7fb5f46f59f862b4d282af61e3bf413e706b3ad.tar.xz
golang-1.22-c7fb5f46f59f862b4d282af61e3bf413e706b3ad.zip
Merging debian version 1.22.2-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog9
-rw-r--r--debian/patches/0002-cmd-link-internal-riscv64-generate-local-text-symbol.patch43
-rw-r--r--debian/patches/series1
3 files changed, 9 insertions, 44 deletions
diff --git a/debian/changelog b/debian/changelog
index d01f191..8b7172e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+golang-1.22 (1.22.2-1) unstable; urgency=medium
+
+ * Team upload
+ * New upstream version 1.22.2
+ + CVE-2023-45288: http2: close connections when receiving too many headers
+ * Revert "Backport patch to fix external link on riscv64" (applied in 1.22.2)
+
+ -- Shengjing Zhu <zhsj@debian.org> Thu, 04 Apr 2024 04:23:15 +0800
+
golang-1.22 (1.22.1-1~progress7.99u1) graograman-backports; urgency=medium
* Initial reupload to graograman-backports.
diff --git a/debian/patches/0002-cmd-link-internal-riscv64-generate-local-text-symbol.patch b/debian/patches/0002-cmd-link-internal-riscv64-generate-local-text-symbol.patch
deleted file mode 100644
index 1797128..0000000
--- a/debian/patches/0002-cmd-link-internal-riscv64-generate-local-text-symbol.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From: Joel Sing <joel@sing.id.au>
-Date: Tue, 27 Feb 2024 23:57:43 +1100
-Subject: cmd/link/internal/riscv64: generate local text symbols for
- R_RISCV_CALL
-
-Correctly generate local text symbols needed for R_RISCV_CALL when
-external linking. R_RISCV_CALL was added in CL #520095 as a way of
-marking AUIPC+JALR pairs, instead of overloading R_RISCV_PCREL_ITYPE.
-However, genSymsLate was not updated to generate local text symbols
-for the new relocation type, leading to HI20 symbol lookup failures.
-
-This issue is detected by cmd/internal/obj/riscv.TestLargeCall,
-however this is unfortunately skipped in short mode.
-
-Fixes #65646
-
-Change-Id: I8ee0f13791e0628f31657bf7dae2be8482b689b5
-Reviewed-on: https://go-review.googlesource.com/c/go/+/567375
-Reviewed-by: Mauri de Souza Meneguzzo <mauri870@gmail.com>
-Reviewed-by: Carlos Amedee <carlos@golang.org>
-Run-TryBot: Joel Sing <joel@sing.id.au>
-Reviewed-by: Cherry Mui <cherryyz@google.com>
-TryBot-Result: Gopher Robot <gobot@golang.org>
-LUCI-TryBot-Result: Go LUCI <golang-scoped@luci-project-accounts.iam.gserviceaccount.com>
----
- src/cmd/link/internal/riscv64/asm.go | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/cmd/link/internal/riscv64/asm.go b/src/cmd/link/internal/riscv64/asm.go
-index d95de6c..6a4dd01 100644
---- a/src/cmd/link/internal/riscv64/asm.go
-+++ b/src/cmd/link/internal/riscv64/asm.go
-@@ -170,8 +170,8 @@ func genSymsLate(ctxt *ld.Link, ldr *loader.Loader) {
- relocs := ldr.Relocs(s)
- for ri := 0; ri < relocs.Count(); ri++ {
- r := relocs.At(ri)
-- if r.Type() != objabi.R_RISCV_PCREL_ITYPE && r.Type() != objabi.R_RISCV_PCREL_STYPE &&
-- r.Type() != objabi.R_RISCV_TLS_IE {
-+ if r.Type() != objabi.R_RISCV_CALL && r.Type() != objabi.R_RISCV_PCREL_ITYPE &&
-+ r.Type() != objabi.R_RISCV_PCREL_STYPE && r.Type() != objabi.R_RISCV_TLS_IE {
- continue
- }
- if r.Off() == 0 && ldr.SymType(s) == sym.STEXT {
diff --git a/debian/patches/series b/debian/patches/series
index 1b83b77..4764021 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1 @@
0001-Skip-flaky-TestCrashDumpsAllThreads-on-mips64le.patch
-0002-cmd-link-internal-riscv64-generate-local-text-symbol.patch