summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 19:39:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 19:39:24 +0000
commit86afd826b15e30fea9a873efb6322ed9dd8c255d (patch)
treeb7bb6db8ba0c0b60eb26185347d097bae73d9cd2
parentMerging upstream version 2:1.21~3. (diff)
downloadgolang-defaults-86afd826b15e30fea9a873efb6322ed9dd8c255d.tar.xz
golang-defaults-86afd826b15e30fea9a873efb6322ed9dd8c255d.zip
Merging debian version 2:1.21~3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog9
-rw-r--r--debian/control2
-rwxr-xr-xdebian/helpers/getdefault.pl5
3 files changed, 15 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index f1dcf1c..2482e57 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+golang-defaults (2:1.21~3) unstable; urgency=medium
+
+ * Extend golang-go to ppc64, but golang-any still points to gccgo-go
+ on ppc64.
+ This helps packages that want to use golang-go to on ppc64 even if it
+ violates the baseline requirements.
+
+ -- Shengjing Zhu <zhsj@debian.org> Wed, 21 Feb 2024 18:51:50 +0800
+
golang-defaults (2:1.21~2-0.0~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-updates, remaining changes:
diff --git a/debian/control b/debian/control
index d484e9a..8f3d5e2 100644
--- a/debian/control
+++ b/debian/control
@@ -23,7 +23,7 @@ XSBC-Original-Vcs-Git: https://salsa.debian.org/go-team/compiler/golang-defaults
Homepage: https://golang.org
Package: golang-go
-Architecture: amd64 arm64 armel armhf i386 mips mips64el mipsel ppc64el riscv64 s390x
+Architecture: amd64 arm64 armel armhf i386 mips mips64el mipsel ppc64 ppc64el riscv64 s390x
Multi-Arch: same
Depends: golang-${golang:Version}-go,
golang-src (>= ${source:Version}),
diff --git a/debian/helpers/getdefault.pl b/debian/helpers/getdefault.pl
index 0c12743..49ca758 100755
--- a/debian/helpers/getdefault.pl
+++ b/debian/helpers/getdefault.pl
@@ -7,6 +7,11 @@ use strict;
use Debian::Debhelper::Dh_Lib;
+if (hostarch() eq "ppc64") {
+ printf("gccgo-go\n");
+ exit 0;
+}
+
my %known_packages = map { $_ => 1 } getpackages('arch');
if (exists($known_packages{'golang-go'})) {
printf("golang-go\n");