summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 19:06:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 19:06:17 +0000
commitb75160fc984d6603da25b9540fa18cf2eb086483 (patch)
tree6a26765b8ee6e501ff0e659f52a4bad16b3a40c5
parentAdding debian version 0.12.2-1~exp1. (diff)
downloadlnav-debian.tar.xz
lnav-debian.zip
Adding debian version 0.12.2-1~exp2.debian/0.12.2-1_exp2debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/tests-try-to-address-some-test-issues.patch89
3 files changed, 96 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index b8a5d64..b3c38e6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+lnav (0.12.2-1~exp2) experimental; urgency=medium
+
+ * try to address some test issues
+
+ -- Salvatore Bonaccorso <carnil@debian.org> Fri, 10 May 2024 22:20:40 +0200
+
lnav (0.12.2-1~exp1) experimental; urgency=medium
* New upstream version 0.12.2
diff --git a/debian/patches/series b/debian/patches/series
index 649c727..8b3603f 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -9,3 +9,4 @@ disable-test_sql_json_func.patch
disable-test_cli.patch
disable-test_sql_str_func.patch
disable-test_text_file.patch
+tests-try-to-address-some-test-issues.patch
diff --git a/debian/patches/tests-try-to-address-some-test-issues.patch b/debian/patches/tests-try-to-address-some-test-issues.patch
new file mode 100644
index 0000000..d7447d1
--- /dev/null
+++ b/debian/patches/tests-try-to-address-some-test-issues.patch
@@ -0,0 +1,89 @@
+From efb85ed5707ffb0a1ca0957b2349971f28fb2270 Mon Sep 17 00:00:00 2001
+From: Tim Stack <timothyshanestack@gmail.com>
+Date: Thu, 9 May 2024 15:41:30 -0700
+Subject: [PATCH] [tests] try to address some test issues
+
+---
+ src/base/humanize.time.cc | 9 +++++----
+ src/lnav_commands.cc | 10 ++--------
+ src/third-party/rapidyaml/ryml_all.hpp | 5 +++++
+ test/test_cmds.sh | 3 +++
+ 4 files changed, 15 insertions(+), 12 deletions(-)
+
+--- a/src/base/humanize.time.cc
++++ b/src/base/humanize.time.cc
+@@ -57,8 +57,9 @@ point::as_time_ago() const
+ current_time.tv_sec = convert_log_time_to_local(current_time.tv_sec);
+ }
+
+- auto delta
+- = std::chrono::seconds(current_time.tv_sec - this->p_past_point.tv_sec);
++ auto curr_secs = std::chrono::seconds(current_time.tv_sec);
++ auto past_secs = std::chrono::seconds(this->p_past_point.tv_sec);
++ auto delta = curr_secs - past_secs;
+ if (delta < 0s) {
+ return "in the future";
+ }
+@@ -113,8 +114,8 @@ point::as_precise_time_ago() const
+ return fmt::format(FMT_STRING("{:2} seconds ago"), diff.tv_sec);
+ }
+
+- time_t seconds = diff.tv_sec % 60;
+- time_t minutes = diff.tv_sec / 60;
++ lnav::time64_t seconds = diff.tv_sec % 60;
++ lnav::time64_t minutes = diff.tv_sec / 60;
+
+ return fmt::format(FMT_STRING("{:2} minute{} and {:2} second{} ago"),
+ minutes,
+--- a/src/lnav_commands.cc
++++ b/src/lnav_commands.cc
+@@ -316,15 +316,12 @@ com_unix_time(exec_context& ec,
+ }
+ if (parsed) {
+ char ftime[128];
+- int len;
+
+ strftime(ftime,
+ sizeof(ftime),
+ "%a %b %d %H:%M:%S %Y %z %Z",
+ localtime_r(&u_time, &log_time));
+- len = strlen(ftime);
+- snprintf(ftime + len, sizeof(ftime) - len, " -- %ld", u_time);
+- retval = std::string(ftime);
++ retval = fmt::format(FMT_STRING("{} -- {}"), ftime, u_time);
+ } else {
+ return ec.make_error("invalid unix time -- {}", args[1]);
+ }
+@@ -659,7 +656,6 @@ com_current_time(exec_context& ec,
+ struct tm localtm;
+ std::string retval;
+ time_t u_time;
+- size_t len;
+
+ memset(&localtm, 0, sizeof(localtm));
+ u_time = time(nullptr);
+@@ -667,9 +663,7 @@ com_current_time(exec_context& ec,
+ sizeof(ftime),
+ "%a %b %d %H:%M:%S %Y %z %Z",
+ localtime_r(&u_time, &localtm));
+- len = strlen(ftime);
+- snprintf(ftime + len, sizeof(ftime) - len, " -- %ld", u_time);
+- retval = std::string(ftime);
++ retval = fmt::format(FMT_STRING("{} -- {}"), ftime, u_time);
+
+ return Ok(retval);
+ }
+--- a/src/third-party/rapidyaml/ryml_all.hpp
++++ b/src/third-party/rapidyaml/ryml_all.hpp
+@@ -498,6 +498,11 @@ C4_FOR_EACH(PRN_STRUCT_OFFSETS, a, b, c)
+ #endif
+ #define C4_BYTE_ORDER _C4EL
+
++#elif defined(mips) || defined(__mips__) || defined(__mips)
++
++ #define C4_WORDSIZE 8
++ #define C4_BYTE_ORDER _C4EL
++
+ #elif defined(__EMSCRIPTEN__)
+ # define C4_BYTE_ORDER _C4EL
+ # define C4_WORDSIZE 4