summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 20:21:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 20:21:35 +0000
commitb6b2f0c15e1167cf21c033e49c35af54bd828331 (patch)
tree3c5f7d8c2341c7711d912fe81088f6f4489ac2e5
parentAdding upstream version 1.3.0. (diff)
downloadpygls-debian.tar.xz
pygls-debian.zip
Adding debian version 1.3.0-2.debian/1.3.0-2debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog11
-rw-r--r--debian/control30
-rw-r--r--debian/copyright51
-rw-r--r--debian/patches/0001_disable_hanging_tests.patch65
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/source/format1
7 files changed, 163 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..70ce2ee
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,11 @@
+pygls (1.3.0-2) unstable; urgency=medium
+
+ * Source-only upload now that the upload has passed NEW.
+
+ -- Niels Thykier <niels@thykier.net> Sat, 24 Feb 2024 18:23:38 +0000
+
+pygls (1.3.0-1) unstable; urgency=medium
+
+ * Initial release.
+
+ -- Niels Thykier <niels@thykier.net> Mon, 19 Feb 2024 12:59:57 +0000
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..f66371a
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,30 @@
+Source: pygls
+Section: python
+Priority: optional
+Maintainer: Niels Thykier <niels@thykier.net>
+Standards-Version: 4.6.2
+Build-Depends: debhelper-compat (= 13),
+ dh-sequence-python3,
+ python3,
+ python3-cattr,
+ python3-lsprotocol,
+ python3-poetry-core,
+ python3-websocket,
+ python3-sphinx-rtd-theme,
+ python3-pytest <!nocheck>,
+ python3-pytest-asyncio <!nocheck>,
+ pybuild-plugin-pyproject,
+ sphinx-doc,
+Rules-Requires-Root: no
+Homepage: https://github.com/openlawlibrary/pygls
+Vcs-Git: https://salsa.debian.org/debian/pygls
+Vcs-Browser: https://salsa.debian.org/debian/pygls
+
+Package: python3-pygls
+Architecture: all
+Depends: ${misc:Depends}, ${python3:Depends}
+Suggests: python3-websockets
+Description: Generic Language Server Framework for Python
+ pygls (pronounced like "pie glass") is a pythonic generic implementation
+ of the Language Server Protocol for use as a foundation for writing your
+ own Language Servers in just a few lines of code.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..7bc18a4
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,51 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+
+Files: *
+Copyright: Copyright(c) Open Law Library. All rights reserved.
+License: Apache-2.0
+
+Files: pygls/__init__.py
+ pygls/exceptions.py
+ pygls/uris.py
+ pygls/workspace/position_codec.py
+ pygls/workspace/text_document.py
+ pygls/workspace/workspace.py
+ tests/__init__.py
+ tests/client.py
+ tests/conftest.py
+ tests/test_document.py
+ tests/test_types.py
+ tests/test_uris.py
+ tests/test_workspace.py
+Copyright: Copyright(c) Open Law Library. All rights reserved.
+ Copyright 2017-2018 Palantir Technologies, Inc.
+License: MIT and Apache-2.0
+
+Files: examples/vscode-playground/src/extension.ts
+Copyright: Copyright (c) Microsoft Corporation. All rights reserved.
+ Copyright (c) Open Law Library. All rights reserved.
+License: MIT and Apache-2.0
+
+License: MIT
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to deal
+ in the Software without restriction, including without limitation the rights
+ to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+ .
+ The above copyright notice and this permission notice shall be included in all
+ copies or substantial portions of the Software.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ SOFTWARE.
+
+License: Apache-2.0
+ The full details of the Apache-2 license is available on
+ Debian systems in the file /usr/share/common-licenses/Apache-2.0
+
diff --git a/debian/patches/0001_disable_hanging_tests.patch b/debian/patches/0001_disable_hanging_tests.patch
new file mode 100644
index 0000000..c53832d
--- /dev/null
+++ b/debian/patches/0001_disable_hanging_tests.patch
@@ -0,0 +1,65 @@
+Disable some tests that hang during Debian builds
+
+--- pygls-1.3.0.orig/tests/lsp/test_code_action.py
++++ pygls-1.3.0/tests/lsp/test_code_action.py
+@@ -20,7 +20,9 @@ from lsprotocol import types
+
+ from ..client import LanguageClient
+
++import pytest
+
++@pytest.mark.skip("Hangs")
+ async def test_code_actions(
+ code_action_client: Tuple[LanguageClient, types.InitializeResult], uri_for
+ ):
+--- pygls-1.3.0.orig/tests/lsp/test_completion.py
++++ pygls-1.3.0/tests/lsp/test_completion.py
+@@ -21,7 +21,10 @@ from lsprotocol import types
+
+ from ..client import LanguageClient
+
++import pytest
+
++
++@pytest.mark.skip("Hangs")
+ async def test_completion(
+ json_server_client: Tuple[LanguageClient, types.InitializeResult],
+ uri_for,
+--- pygls-1.3.0.orig/tests/lsp/test_diagnostics.py
++++ pygls-1.3.0/tests/lsp/test_diagnostics.py
+@@ -22,7 +22,10 @@ from lsprotocol import types
+
+ from ..client import LanguageClient
+
++import pytest
+
++
++@pytest.mark.skip("Hangs")
+ async def test_diagnostics(
+ json_server_client: Tuple[LanguageClient, types.InitializeResult],
+ uri_for,
+--- pygls-1.3.0.orig/tests/lsp/test_inlay_hints.py
++++ pygls-1.3.0/tests/lsp/test_inlay_hints.py
+@@ -20,7 +20,10 @@ from lsprotocol import types
+
+ from ..client import LanguageClient
+
++import pytest
+
++
++@pytest.mark.skip("Hangs")
+ async def test_code_actions(
+ inlay_hints_client: Tuple[LanguageClient, types.InitializeResult], uri_for
+ ):
+--- pygls-1.3.0.orig/tests/lsp/test_inline_value.py
++++ pygls-1.3.0/tests/lsp/test_inline_value.py
+@@ -21,7 +21,9 @@ from lsprotocol import types
+
+ from ..client import LanguageClient
+
++import pytest
+
++@pytest.mark.skip("Hangs")
+ async def test_inline_value(
+ json_server_client: Tuple[LanguageClient, types.InitializeResult],
+ uri_for,
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..84074ea
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0001_disable_hanging_tests.patch
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..9cc9c17
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,4 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@ -S pybuild
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)