summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 16:23:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 16:23:18 +0000
commit07a6cedcf0acaee85bd4fb11b583263535a6db95 (patch)
tree2cd9a7a2f644a1ad492c06554ea18e315cac5c49
parentMerging upstream version 0.0~git20230113.4362b18. (diff)
downloadwasi-libc-07a6cedcf0acaee85bd4fb11b583263535a6db95.tar.xz
wasi-libc-07a6cedcf0acaee85bd4fb11b583263535a6db95.zip
Merging debian version 0.0~git20230113.4362b18-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog17
-rw-r--r--debian/control2
-rw-r--r--debian/copyright10
-rw-r--r--debian/patches/debian-flags.patch37
-rw-r--r--debian/patches/disable-warning.patch12
-rw-r--r--debian/patches/dont-rebuild-install.patch20
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/wasi-libc.lintian-overrides3
8 files changed, 73 insertions, 32 deletions
diff --git a/debian/changelog b/debian/changelog
index cb62306..3563c1e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,20 @@
+wasi-libc (0.0~git20230113.4362b18-1) unstable; urgency=medium
+
+ * Upload to unstable
+
+ -- Fabian Grünbichler <debian@fabian.gruenbichler.email> Sun, 10 Sep 2023 19:22:19 +0200
+
+wasi-libc (0.0~git20230113.4362b18-1~exp1) experimental; urgency=medium
+
+ * new upstream version needed for rustc 1.68.2+
+ * build: enable stack protection
+ * d/control: update Standards-Version
+ * update d/copyright
+ * cleanup lintian overrides
+ * add DEP-3 metadata to patches
+
+ -- Fabian Grünbichler <debian@fabian.gruenbichler.email> Fri, 08 Sep 2023 09:56:09 +0200
+
wasi-libc (0.0~git20221206.8b7148f-1~progress7.99u1) graograman-backports; urgency=medium
* Initial reupload to graograman-backports.
diff --git a/debian/control b/debian/control
index e9a6adc..0ed5ec9 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ XSBC-Original-Uploaders:
Fabian Grünbichler <debian@fabian.gruenbichler.email>
Bugs: mailto:maintainers@lists.progress-linux.org
Build-Depends: debhelper-compat (= 13), clang-14, llvm-14
-Standards-Version: 4.6.1
+Standards-Version: 4.6.2
Homepage: https://github.com/CraneStation/wasi-libc
Vcs-Browser: https://git.progress-linux.org/packages/graograman-backports/wasi-libc
Vcs-Git: https://git.progress-linux.org/packages/graograman-backports/wasi-libc
diff --git a/debian/copyright b/debian/copyright
index 3e5d175..f9a9364 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -17,12 +17,6 @@ Files: libc-bottom-half/cloudlibc/*
Copyright: 2015-2017 Nuxi (https://nuxi.nl/) and contributors
License: BSD-2-clause
-Files: libc-bottom-half/libpreopen/*
-Copyright:
- 2016-2017 Stanley Uche Godfrey
- 2016-2018 Jonathan Anderson
-License: BSD-2-clause
-
Files: tools/wasi-headers/*
Copyright:
2018-2020 Dan Gohman <sunfish@mozilla.com>
@@ -221,10 +215,6 @@ Copyright: 2016 Mahesh Bodapati
2016 Imagination Technologies
License: MIT
-Files: libc-top-half/musl/src/string/arm/memcpy_le.S
-Copyright: 2008 The Android Open Source Project
-License: BSD-2-clause
-
License: MIT
Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the "Software"),
diff --git a/debian/patches/debian-flags.patch b/debian/patches/debian-flags.patch
index 3c8ef0b..d9ca6f8 100644
--- a/debian/patches/debian-flags.patch
+++ b/debian/patches/debian-flags.patch
@@ -1,5 +1,12 @@
---- a/expected/wasm32-wasi/posix/predefined-macros.txt
-+++ b/expected/wasm32-wasi/posix/predefined-macros.txt
+Author: Ximin Luo <infinity0@debian.org>
+Description: patch aligning expected definitions to Debian
+peculiarities/toolchain versions.
+Forwarded: not-needed
+
+Index: wasi-libc/expected/wasm32-wasi-threads/predefined-macros.txt
+===================================================================
+--- wasi-libc.orig/expected/wasm32-wasi-threads/predefined-macros.txt
++++ wasi-libc/expected/wasm32-wasi-threads/predefined-macros.txt
@@ -1119,7 +1119,6 @@
#define NAN (0.0f/0.0f)
#define NBBY 8
@@ -8,7 +15,15 @@
#define ND_NA_FLAG_OVERRIDE 0x00000020
#define ND_NA_FLAG_ROUTER 0x00000080
#define ND_NA_FLAG_SOLICITED 0x00000040
-@@ -3113,7 +3112,7 @@
+@@ -2728,6 +2727,7 @@
+ #define __SIZE_MAX__ 4294967295UL
+ #define __SIZE_TYPE__ long unsigned int
+ #define __SIZE_WIDTH__ 32
++#define __SSP_STRONG__ 2
+ #define __STDARG_H
+ #define __STDC_HOSTED__ 1
+ #define __STDC_IEC_559__ 1
+@@ -3112,7 +3112,7 @@
#define and_eq &=
#define asin(x) __tg_real_complex(asin, (x))
#define asinh(x) __tg_real_complex(asinh, (x))
@@ -17,8 +32,10 @@
#define atan(x) __tg_real_complex(atan, (x))
#define atan2(x,y) __tg_real_2(atan2, (x), (y))
#define atanh(x) __tg_real_complex(atanh, (x))
---- a/expected/wasm32-wasi/single/predefined-macros.txt
-+++ b/expected/wasm32-wasi/single/predefined-macros.txt
+Index: wasi-libc/expected/wasm32-wasi/predefined-macros.txt
+===================================================================
+--- wasi-libc.orig/expected/wasm32-wasi/predefined-macros.txt
++++ wasi-libc/expected/wasm32-wasi/predefined-macros.txt
@@ -1119,7 +1119,6 @@
#define NAN (0.0f/0.0f)
#define NBBY 8
@@ -27,7 +44,15 @@
#define ND_NA_FLAG_OVERRIDE 0x00000020
#define ND_NA_FLAG_ROUTER 0x00000080
#define ND_NA_FLAG_SOLICITED 0x00000040
-@@ -3073,7 +3072,7 @@
+@@ -2691,6 +2690,7 @@
+ #define __SIZE_MAX__ 4294967295UL
+ #define __SIZE_TYPE__ long unsigned int
+ #define __SIZE_WIDTH__ 32
++#define __SSP_STRONG__ 2
+ #define __STDARG_H
+ #define __STDC_HOSTED__ 1
+ #define __STDC_IEC_559__ 1
+@@ -3073,7 +3073,7 @@
#define and_eq &=
#define asin(x) __tg_real_complex(asin, (x))
#define asinh(x) __tg_real_complex(asinh, (x))
diff --git a/debian/patches/disable-warning.patch b/debian/patches/disable-warning.patch
index 46098d4..c6256b5 100644
--- a/debian/patches/disable-warning.patch
+++ b/debian/patches/disable-warning.patch
@@ -1,6 +1,12 @@
---- a/Makefile
-+++ b/Makefile
-@@ -294,6 +294,7 @@
+Author: Fabian Grünbichler <debian@fabian.gruenbichler.email>
+Description: disable on-by-default linker warning
+Forwarded: not-needed
+
+Index: wasi-libc/Makefile
+===================================================================
+--- wasi-libc.orig/Makefile
++++ wasi-libc/Makefile
+@@ -310,6 +310,7 @@ CFLAGS += -Wall -Wextra -Werror \
-Wno-missing-braces \
-Wno-ignored-pragmas \
-Wno-unused-but-set-variable \
diff --git a/debian/patches/dont-rebuild-install.patch b/debian/patches/dont-rebuild-install.patch
index a72b006..a9cf7f7 100644
--- a/debian/patches/dont-rebuild-install.patch
+++ b/debian/patches/dont-rebuild-install.patch
@@ -1,6 +1,12 @@
---- a/Makefile
-+++ b/Makefile
-@@ -556,6 +556,8 @@
+Author: Ximin Luo <infinity0@debian.org>
+Description: Prevent spurious rebuilds
+Forwarded: not-needed
+
+Index: wasi-libc/Makefile
+===================================================================
+--- wasi-libc.orig/Makefile
++++ wasi-libc/Makefile
+@@ -577,6 +577,8 @@ include_dirs:
# Remove selected header files.
$(RM) $(patsubst %,$(SYSROOT_INC)/%,$(MUSL_OMIT_HEADERS))
@@ -9,7 +15,7 @@
startup_files: include_dirs
#
# Build the startup files.
-@@ -566,6 +568,8 @@
+@@ -587,6 +589,8 @@ startup_files: include_dirs
mkdir -p "$(SYSROOT_LIB)" && \
mv *.o "$(SYSROOT_LIB)"
@@ -18,7 +24,7 @@
libc: include_dirs \
$(SYSROOT_LIB)/libc.a \
$(SYSROOT_LIB)/libc-printscan-long-double.a \
-@@ -575,6 +579,8 @@
+@@ -596,6 +600,8 @@ libc: include_dirs \
$(SYSROOT_LIB)/libwasi-emulated-getpid.a \
$(SYSROOT_LIB)/libwasi-emulated-signal.a
@@ -27,7 +33,7 @@
finish: startup_files libc
#
# Create empty placeholder libraries.
-@@ -586,6 +592,7 @@
+@@ -607,6 +613,7 @@ finish: startup_files libc
#
# The build succeeded! The generated sysroot is in $(SYSROOT).
#
@@ -35,7 +41,7 @@
# The check for defined and undefined symbols expects there to be a heap
# alloctor (providing malloc, calloc, free, etc). Skip this step if the build
-@@ -687,5 +694,6 @@
+@@ -712,5 +719,6 @@ install: finish
clean:
$(RM) -r "$(OBJDIR)"
$(RM) -r "$(SYSROOT)"
diff --git a/debian/rules b/debian/rules
index dca6423..66b53d1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,9 +9,7 @@ export NM = llvm-nm-14
export AR = llvm-ar-14
export CC = clang-14
-# stack protector not yet supported, see
-# https://github.com/CraneStation/wasi-libc/issues/157
-export EXTRA_CFLAGS = $(CFLAGS) $(LDFLAGS) -fno-stack-protector -fcf-protection=none
+export EXTRA_CFLAGS = $(CFLAGS) $(LDFLAGS) -fcf-protection=none
%:
dh $@
diff --git a/debian/wasi-libc.lintian-overrides b/debian/wasi-libc.lintian-overrides
index adac81e..0d03bf9 100644
--- a/debian/wasi-libc.lintian-overrides
+++ b/debian/wasi-libc.lintian-overrides
@@ -1,6 +1,5 @@
# wasm object files count as arch-independent for now,
# at least until we starting offering Debian in wasm
-wasi-libc: arch-independent-package-contains-binary-or-object [usr/lib/*-wasi/*.a]
wasi-libc: no-code-sections [usr/lib/*-wasi/*.a]
# this one is for ftp-masters, which uses bullseye lintian with different output!
-wasi-libc binary: arch-independent-package-contains-binary-or-object usr/lib/*-wasi/*.a
+wasi-libc binary: arch-independent-package-contains-binary-or-object *usr/lib/*-wasi/*.a*