summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 08:29:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 08:29:33 +0000
commit317d948f8bac3b3d7b84e05306ca6cffd1daeb53 (patch)
tree101808ca1723399f54f5b5b85545fa0c03be3989
parentUpdating vcs fields. (diff)
downloadcryptsetup-317d948f8bac3b3d7b84e05306ca6cffd1daeb53.tar.xz
cryptsetup-317d948f8bac3b3d7b84e05306ca6cffd1daeb53.zip
Using decrypt_keyctl by default if no keyscript in /etc/crypttab to cache passphrase for multiple filesystems.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/control3
-rw-r--r--debian/functions5
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index 80eb667..9515d7f 100644
--- a/debian/control
+++ b/debian/control
@@ -46,9 +46,10 @@ Architecture: linux-any
Multi-Arch: foreign
Depends: cryptsetup-bin (>= 2:1.6.0),
dmsetup,
+ keyutils,
${misc:Depends},
${shlibs:Depends}
-Suggests: cryptsetup-initramfs, dosfstools, keyutils, liblocale-gettext-perl
+Suggests: cryptsetup-initramfs, dosfstools, liblocale-gettext-perl
Replaces: cryptsetup-run (<< 2:2.1.0-6)
Breaks: cryptsetup-run (<< 2:2.1.0-6)
Description: disk encryption support - startup scripts
diff --git a/debian/functions b/debian/functions
index 917abad..3409787 100644
--- a/debian/functions
+++ b/debian/functions
@@ -113,6 +113,11 @@ crypttab_parse_options() {
done
IFS=" "
+ # use decrypt_keyctl by default if no keyscript in /etc/crypttab
+ if [ -z "$CRYPTTAB_OPTION_keyscript" ]; then
+ CRYPTTAB_OPTION_keyscript="/lib/cryptsetup/scripts/decrypt_keyctl"
+ fi
+
if ! _get_crypt_type; then # set CRYPTTAB_TYPE to the type of crypt device
CRYPTTAB_TYPE="plain"
if [ "$quiet" = "n" ]; then