summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 11:18:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 11:18:13 +0000
commitfcc58c19e62d88e3bf38216c812a79313c2c73ff (patch)
tree0a9f9336e7826b2ebb1833848e97a202a89f45f7
parentReleasing progress-linux version 20240420-3progress7u1. (diff)
downloadprogress-linux-fcc58c19e62d88e3bf38216c812a79313c2c73ff.tar.xz
progress-linux-fcc58c19e62d88e3bf38216c812a79313c2c73ff.zip
Merging debian version 20240420-4.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog10
-rwxr-xr-xdebian/progress-linux.config23
2 files changed, 27 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 6915bd4..d68532b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+progress-linux (20240420-4) sid; urgency=medium
+
+ * Uploading to sid.
+ * Using dot after major version in progress-linux version handling for
+ consistency.
+ * Adding legacy handling for non-free/non-free-firmware archive areas so
+ that the same package can be used on all support releases.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Sun, 28 Apr 2024 13:16:26 +0200
+
progress-linux (20240420-3progress7u1) graograman; urgency=medium
* Uploading to graograman, remaining changes:
diff --git a/debian/progress-linux.config b/debian/progress-linux.config
index 6939689..991cfd5 100755
--- a/debian/progress-linux.config
+++ b/debian/progress-linux.config
@@ -9,10 +9,21 @@ PROJECT="progress-linux"
Run_debconf ()
{
+ # non-free archive areas
+ case "${RELEASE}" in
+ 5|6)
+ NON_FREE="non-free"
+ ;;
+
+ *)
+ NON_FREE="non-free, non-free-firmware"
+ ;;
+ esac
+
# debconf templates
db_subst ${PROJECT}/archives CHOICES "${NAME} ${RELEASE} (${CODENAME}), ${NAME} ${RELEASE} (${CODENAME}-security), ${NAME} ${RELEASE} (${CODENAME}-updates), ${NAME} ${RELEASE} (${CODENAME}-extras), ${NAME} ${RELEASE} (${CODENAME}-test), ${NAME} ${RELEASE}.99 (${CODENAME}-backports), ${NAME} ${RELEASE}.99 (${CODENAME}-backports-extras), ${NAME} ${RELEASE}.99 (${CODENAME}-backports-test)"
db_subst ${PROJECT}/archives CHOICES_C "${CODENAME}, ${CODENAME}-security, ${CODENAME}-updates, ${CODENAME}-extras, ${CODENAME}-test, ${CODENAME}-backports, ${CODENAME}-backports-extras, ${CODENAME}-backports-test"
- db_subst ${PROJECT}/archive-areas CHOICES "main, contrib, non-free, non-free-firmware, restricted"
+ db_subst ${PROJECT}/archive-areas CHOICES "main, contrib, ${NON_FREE}, restricted"
# apt archives
db_settitle ${PROJECT}/title
@@ -39,35 +50,35 @@ PROGRESS_LINUX_VERSION="$(if [ -e /etc/progress-linux_version ]; then cat /etc/p
if [ -n "${PROGRESS_LINUX_VERSION}" ]
then
case "${PROGRESS_LINUX_VERSION}" in
- 5*)
+ 5.*)
RELEASE="5"
CODENAME="engywuck"
Run_debconf
;;
- 6*)
+ 6.*)
RELEASE="6"
CODENAME="fuchur"
Run_debconf
;;
- 7*)
+ 7.*)
RELEASE="7"
CODENAME="graograman"
Run_debconf
;;
- 8*)
+ 8.*)
RELEASE="8"
CODENAME="horok"
Run_debconf
;;
- 9*)
+ 9.*)
RELEASE="9"
CODENAME="illuan"