summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-01-31 05:31:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-01-31 05:31:44 +0000
commit4030bf173eefa59aa60e38ec9ba28f0a8f741afb (patch)
tree75d431ddd5bf3bb4ba4f8aac394a41ec7e7a3394
parentReleasing debian version 1.24~rc2-1. (diff)
downloadlzip-4030bf173eefa59aa60e38ec9ba28f0a8f741afb.tar.xz
lzip-4030bf173eefa59aa60e38ec9ba28f0a8f741afb.zip
Merging upstream version 1.24.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--ChangeLog27
-rw-r--r--Makefile.in4
-rw-r--r--NEWS2
-rwxr-xr-xconfigure2
-rw-r--r--doc/lzip.12
-rw-r--r--doc/lzip.info34
-rw-r--r--doc/lzip.texi4
-rw-r--r--main.cc2
8 files changed, 34 insertions, 43 deletions
diff --git a/ChangeLog b/ChangeLog
index da283f9..4ed04db 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,14 +1,10 @@
-2024-01-19 Antonio Diaz Diaz <antonio@gnu.org>
+2024-01-26 Antonio Diaz Diaz <antonio@gnu.org>
- * Version 1.24-rc2 released.
- * main.cc (main): Make -o preserve date/mode/owner if 1 input file.
-
-2023-12-21 Antonio Diaz Diaz <antonio@gnu.org>
-
- * Version 1.24-rc1 released.
+ * Version 1.24 released.
* New options '--empty-error' and '--marking-error'.
* main.cc: Reformat file diagnostics as 'PROGRAM: FILE: MESSAGE'.
(show_option_error): New function showing argument and option name.
+ (main): Make -o preserve date/mode/owner if 1 input file.
(open_outstream): Create missing intermediate directories.
* lzip.h: Rename verify_* to check_*.
* configure, Makefile.in: New variable 'MAKEINFO'.
@@ -162,8 +158,8 @@
* Compression time of option '-0' has been reduced by 2%.
* main.cc (decompress): Print only one status line for each
multimember file when only one '-v' is specified.
- * main.cc (decompress): Print up to 6 bytes of trailing data
- when '-vvvv' is specified.
+ * main.cc (decompress): Print up to 6 bytes of trailing data when
+ '-vvvv' is specified.
* main.cc (open_instream): Don't show the message
" and '--stdout' was not specified" for directories, etc.
* lziprecover.cc: If '-v' is not specified show errors only.
@@ -192,8 +188,8 @@
This change also prevents (harmless) access to uninitialized
memory when decompressing a corrupt file.
* lziprecover.cc: New options '-f, --force' and '-o, --output'.
- * lziprecover.cc: New option '-s, --split' to select the until
- now only operation of splitting multimember files.
+ * lziprecover.cc: New option '-s, --split' to select the until now
+ only operation of splitting multimember files.
* lziprecover.cc: If no operation is specified, warn the user and do
nothing.
* main.cc: Fix warning about fchown's return value being ignored.
@@ -292,8 +288,8 @@
* Version 1.2 released.
* encoder.cc: A 1-byte read outside allocated memory has been fixed.
- * lzip.h: Dictionary size limit has been reduced to 512MiB because
- setting it to 1GiB causes overflow of a 32 bit integer.
+ * lzip.h: Dictionary size limit has been reduced to 512 MiB because
+ setting it to 1 GiB causes overflow of a 32 bit integer.
* Add 'lzdiff', a diff/cmp wrapper for gzip, bzip2, lzip and
non-compressed files.
* Add 'lzgrep', a grep wrapper for gzip, bzip2, lzip and
@@ -345,6 +341,5 @@
Copyright (C) 2008-2024 Antonio Diaz Diaz.
-This file is a collection of facts, and thus it is not copyrightable,
-but just in case, you have unlimited permission to copy, distribute, and
-modify it.
+This file is a collection of facts, and thus it is not copyrightable, but just
+in case, you have unlimited permission to copy, distribute, and modify it.
diff --git a/Makefile.in b/Makefile.in
index adf90e0..2b7f23c 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -28,10 +28,6 @@ main.o : main.cc
%.o : %.cc
$(CXX) $(CPPFLAGS) $(CXXFLAGS) -c -o $@ $<
-# prevent 'make' from trying to remake source files
-$(VPATH)/configure $(VPATH)/Makefile.in $(VPATH)/doc/$(pkgname).texi : ;
-%.h %.cc : ;
-
$(objs) : Makefile
arg_parser.o : arg_parser.h
decoder.o : lzip.h decoder.h
diff --git a/NEWS b/NEWS
index d29f243..9a97821 100644
--- a/NEWS
+++ b/NEWS
@@ -12,7 +12,7 @@ Diagnostics caused by invalid arguments to command-line options now show the
argument and the name of the option.
The option '-o, --output' now preserves dates, permissions, and ownership of
-the file, when (de)compressing exactly one file.
+the file when (de)compressing exactly one file.
The option '-o, --output' now creates missing intermediate directories when
writing to a file.
diff --git a/configure b/configure
index f0783cb..012fb5c 100755
--- a/configure
+++ b/configure
@@ -6,7 +6,7 @@
# to copy, distribute, and modify it.
pkgname=lzip
-pkgversion=1.24-rc2
+pkgversion=1.24
progname=lzip
srctrigger=doc/${pkgname}.texi
diff --git a/doc/lzip.1 b/doc/lzip.1
index 824a113..9053c43 100644
--- a/doc/lzip.1
+++ b/doc/lzip.1
@@ -1,5 +1,5 @@
.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.49.2.
-.TH LZIP "1" "January 2024" "lzip 1.24-rc2" "User Commands"
+.TH LZIP "1" "January 2024" "lzip 1.24" "User Commands"
.SH NAME
lzip \- reduces the size of files
.SH SYNOPSIS
diff --git a/doc/lzip.info b/doc/lzip.info
index 5c397d3..1e23532 100644
--- a/doc/lzip.info
+++ b/doc/lzip.info
@@ -11,7 +11,7 @@ File: lzip.info, Node: Top, Next: Introduction, Up: (dir)
Lzip Manual
***********
-This manual is for Lzip (version 1.24-rc2, 19 January 2024).
+This manual is for Lzip (version 1.24, 26 January 2024).
* Menu:
@@ -1703,22 +1703,22 @@ Concept index

Tag Table:
Node: Top203
-Node: Introduction1202
-Node: Output7087
-Node: Invoking lzip8682
-Ref: --trailing-error9551
-Node: Quality assurance19649
-Node: Algorithm28462
-Node: File format31863
-Ref: coded-dict-size33292
-Node: Stream format34523
-Ref: what-is-coded36918
-Node: Trailing data45792
-Node: Examples48128
-Ref: concat-example49568
-Node: Problems50789
-Node: Reference source code51321
-Node: Concept index66366
+Node: Introduction1198
+Node: Output7083
+Node: Invoking lzip8678
+Ref: --trailing-error9547
+Node: Quality assurance19645
+Node: Algorithm28458
+Node: File format31859
+Ref: coded-dict-size33288
+Node: Stream format34519
+Ref: what-is-coded36914
+Node: Trailing data45788
+Node: Examples48124
+Ref: concat-example49564
+Node: Problems50785
+Node: Reference source code51317
+Node: Concept index66362

End Tag Table
diff --git a/doc/lzip.texi b/doc/lzip.texi
index 7e6223c..6d5cf77 100644
--- a/doc/lzip.texi
+++ b/doc/lzip.texi
@@ -6,8 +6,8 @@
@finalout
@c %**end of header
-@set UPDATED 19 January 2024
-@set VERSION 1.24-rc2
+@set UPDATED 26 January 2024
+@set VERSION 1.24
@dircategory Compression
@direntry
diff --git a/main.cc b/main.cc
index 5db46f2..1a905a8 100644
--- a/main.cc
+++ b/main.cc
@@ -26,7 +26,7 @@
#include <algorithm>
#include <cctype>
#include <cerrno>
-#include <climits> // SSIZE_MAX
+#include <climits> // CHAR_BIT, SSIZE_MAX
#include <csignal>
#include <cstdio>
#include <cstdlib>