summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 20:15:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 20:15:44 +0000
commitb91f5837f107761e5b86ddd5f39f4aa0b8385ca0 (patch)
treeae618e20fc9f8193a709e98be356438b84a0ef1d /debian/rules
parentAdding upstream version 13.3.4. (diff)
downloaddebhelper-b91f5837f107761e5b86ddd5f39f4aa0b8385ca0.tar.xz
debhelper-b91f5837f107761e5b86ddd5f39f4aa0b8385ca0.zip
Adding debian version 13.3.4.debian/13.3.4debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules23
1 files changed, 23 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..6c01845
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+# If you're looking for an example debian/rules that uses debhelper, see
+# the examples directory.
+#
+# Each debhelper command in this rules file has to be run using ./run,
+# to ensure that the commands and libraries in the source tree are used,
+# rather than the installed ones.
+#
+# We disable autoreconf to avoid build-depending on it (it does
+# nothing for debhelper and it keeps the set of B-D smaller)
+
+PERL ?= perl
+
+%:
+ ./run dh $@ --without autoreconf --with build-stamp
+
+# Disable as they are unneeded (and we can then be sure debhelper
+# builds without needing autotools-dev, dh-strip-nondetermism etc.)
+override_dh_update_autotools_config override_dh_strip_nondeterminism:
+
+execute_before_dh_install:
+ PERLLIBDIR=$$($(PERL) -MConfig -e 'print $$Config{vendorlib}')/ ; \
+ $(PERL) -I"debian/tmp/$${PERLLIBDIR}" debian/gen-provides > debian/debhelper.substvars