summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 20:18:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 20:18:29 +0000
commit20296bbda1d66034bd8bbe26c79b84a045750569 (patch)
tree5323983a422edc16ef69493d893f99dc4a0d9fb3 /debian/rules
parentAdding upstream version 9.11.0. (diff)
downloadrich-debian.tar.xz
rich-debian.zip
Adding debian version 9.11.0-1.debian/9.11.0-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 12 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..553fbff
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,12 @@
+#! /usr/bin/make -f
+
+export PYBUILD_NAME=rich
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+override_dh_auto_install:
+ PYBUILD_SYSTEM=custom PYBUILD_INSTALL_ARGS="{interpreter} debian/setup.py install --root={destdir}" dh_auto_install
+
+override_dh_auto_test:
+ PYBUILD_SYSTEM=custom PYBUILD_TEST_ARGS="PYTHONPATH=$(CURDIR) {interpreter} -m pytest" dh_auto_test