summaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in23
1 files changed, 22 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index 21c76f8..ebf7a16 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -128,7 +128,7 @@ install-conf:
fi
# Create a sanitized config_vars.mk
-build/config_vars.out: build/config_vars.mk
+build/config_vars.out: build/config_vars.mk build/config_vars.sh
@$(SHELL) build/config_vars.sh < build/config_vars.mk > build/config_vars.out
install-build: build/config_vars.out
@@ -155,6 +155,26 @@ docs:
echo ' http://httpd.apache.org/docs-project/docsformat.html'; \
fi
+update-changes:
+ @for i in `find changes-entries -type f`; do \
+ cp CHANGES CHANGES.tmp ; \
+ awk -v fname=$$i 'BEGIN{done = 0; active = 0} \
+ done == 0 && active == 0 && /^Changes with Apache /{ active = 1; print; next}; \
+ /^( *\*|Changes with Apache )/ && active == 1 && done == 0{rec=$$0; while(getline<fname){if (! ($$0 ~ /^ *$$/)){print}}printf "\n";print rec; active = 0; done = 1; next} //;' \
+ CHANGES.tmp > CHANGES ; \
+ rm CHANGES.tmp ; \
+ if [ -n "$(SVN)" ] ; then \
+ if ! $(SVN) rm $$i 2>/dev/null ; then \
+ $(RM) $$i ; \
+ fi ; \
+ else \
+ $(RM) $$i ; \
+ fi ; \
+ done ; \
+ if [ -n "$(SVN)" ] ; then \
+ $(SVN) diff CHANGES ; \
+ fi
+
validate-xml:
@if test -d $(top_srcdir)/docs/manual/build; then \
cd $(top_srcdir)/docs/manual/build && ./build.sh validate-xml; \
@@ -235,6 +255,7 @@ INSTALL_HEADERS = \
$(srcdir)/modules/cache/cache_common.h \
$(srcdir)/modules/database/mod_dbd.h \
$(srcdir)/modules/dav/main/mod_dav.h \
+ $(srcdir)/modules/http2/mod_http2.h \
$(srcdir)/modules/filters/mod_include.h \
$(srcdir)/modules/filters/mod_xml2enc.h \
$(srcdir)/modules/generators/mod_cgi.h \