summaryrefslogtreecommitdiffstats
path: root/debian/patches/0003-Avoid-clobbering-CXX-flags-when-compiling-lua-aho-co.patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:55:53 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:55:53 +0000
commit129b974b59c74140570847bb4a2774d41d1e5fae (patch)
treef2dc68e7186b8157e33aebbc2526e016912ded82 /debian/patches/0003-Avoid-clobbering-CXX-flags-when-compiling-lua-aho-co.patch
parentAdding upstream version 3.2.1. (diff)
downloadknot-resolver-129b974b59c74140570847bb4a2774d41d1e5fae.tar.xz
knot-resolver-129b974b59c74140570847bb4a2774d41d1e5fae.zip
Adding debian version 3.2.1-3.debian/3.2.1-3
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/0003-Avoid-clobbering-CXX-flags-when-compiling-lua-aho-co.patch')
-rw-r--r--debian/patches/0003-Avoid-clobbering-CXX-flags-when-compiling-lua-aho-co.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/debian/patches/0003-Avoid-clobbering-CXX-flags-when-compiling-lua-aho-co.patch b/debian/patches/0003-Avoid-clobbering-CXX-flags-when-compiling-lua-aho-co.patch
new file mode 100644
index 0000000..8d3d869
--- /dev/null
+++ b/debian/patches/0003-Avoid-clobbering-CXX-flags-when-compiling-lua-aho-co.patch
@@ -0,0 +1,24 @@
+From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
+Date: Thu, 7 Mar 2019 14:36:33 -0500
+Subject: Avoid clobbering CXX flags when compiling lua-aho-corasick
+
+Without this patch, any externally-set CXXFLAGS are not passed through
+to the underlying C++ compiler.
+
+---
+ modules/policy/policy.mk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/modules/policy/policy.mk b/modules/policy/policy.mk
+index 98c9f88..43964dd 100644
+--- a/modules/policy/policy.mk
++++ b/modules/policy/policy.mk
+@@ -7,7 +7,7 @@ $(call make_lua_module,policy)
+ policy-clean:
+ $(MAKE) -C $(AHOCORASICK_DIR) clean
+ $(AHOCORASICK_DIR)ahocorasick$(LIBEXT): $(AHOCORASICK_DIR)Makefile
+- $(MAKE) -C $(AHOCORASICK_DIR) ahocorasick$(LIBEXT) CXXFLAGS="$(lua_CFLAGS)"
++ $(MAKE) -C $(AHOCORASICK_DIR) ahocorasick$(LIBEXT) CXXFLAGS="$(lua_CFLAGS) $(CXXFLAGS)"
+
+ policy-install: ahocorasick-install
+ ahocorasick-install: $(AHOCORASICK_DIR)ahocorasick$(LIBEXT) $(DESTDIR)$(MODULEDIR)