summaryrefslogtreecommitdiffstats
path: root/tests/config/test_config.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tests/config/test_config.mk')
-rw-r--r--tests/config/test_config.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/config/test_config.mk b/tests/config/test_config.mk
new file mode 100644
index 0000000..92c3543
--- /dev/null
+++ b/tests/config/test_config.mk
@@ -0,0 +1,24 @@
+#
+# Configuration tests
+#
+# Copy test folder and test_utils.lua to temp directory
+# Run kresd in temp directory and use config test.cfg
+# Check return code of kresd. Passed test have to call quit().
+
+tests_config := \
+ $(wildcard daemon/*/*.test.lua) \
+ $(wildcard daemon/*/*/*.test.lua) \
+ $(wildcard modules/*/*.test.lua) \
+ $(wildcard modules/*/*/*.test.lua) \
+ $(wildcard tests/config/*.test.lua) \
+ $(wildcard tests/config/*/*.test.lua)
+
+define make_config_test
+$(1): check-install-precond
+ @$(shell ./scripts/coverage_env.sh "$(TOPSRCDIR)" "$(COVERAGE_STATSDIR)/tests_config" "$(1)") $(preload_syms) ./tests/config/runtest.sh $(abspath $(SBINDIR)/kresd) $(abspath $(1))
+.PHONY: $(1)
+endef
+
+$(foreach test,$(tests_config),$(eval $(call make_config_test,$(test))))
+check-config: $(tests_config)
+.PHONY: check-config