summaryrefslogtreecommitdiffstats
path: root/arch/ia64/dig/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/ia64/dig/Makefile')
-rw-r--r--arch/ia64/dig/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/arch/ia64/dig/Makefile b/arch/ia64/dig/Makefile
new file mode 100644
index 000000000..e7f830825
--- /dev/null
+++ b/arch/ia64/dig/Makefile
@@ -0,0 +1,15 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# ia64/platform/dig/Makefile
+#
+# Copyright (C) 1999 Silicon Graphics, Inc.
+# Copyright (C) Srinivasa Thirumalachar (sprasad@engr.sgi.com)
+#
+
+obj-y := setup.o
+ifeq ($(CONFIG_INTEL_IOMMU), y)
+obj-$(CONFIG_IA64_GENERIC) += machvec.o machvec_vtd.o
+else
+obj-$(CONFIG_IA64_GENERIC) += machvec.o
+endif
+