summaryrefslogtreecommitdiffstats
path: root/drivers/hwtracing/stm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/hwtracing/stm/Makefile')
-rw-r--r--drivers/hwtracing/stm/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/drivers/hwtracing/stm/Makefile b/drivers/hwtracing/stm/Makefile
new file mode 100644
index 000000000..effc19e51
--- /dev/null
+++ b/drivers/hwtracing/stm/Makefile
@@ -0,0 +1,14 @@
+# SPDX-License-Identifier: GPL-2.0
+obj-$(CONFIG_STM) += stm_core.o
+
+stm_core-y := core.o policy.o
+
+obj-$(CONFIG_STM_DUMMY) += dummy_stm.o
+
+obj-$(CONFIG_STM_SOURCE_CONSOLE) += stm_console.o
+obj-$(CONFIG_STM_SOURCE_HEARTBEAT) += stm_heartbeat.o
+obj-$(CONFIG_STM_SOURCE_FTRACE) += stm_ftrace.o
+
+stm_console-y := console.o
+stm_heartbeat-y := heartbeat.o
+stm_ftrace-y := ftrace.o