summaryrefslogtreecommitdiffstats
path: root/debian/policy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'debian/policy/Makefile')
-rw-r--r--debian/policy/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/policy/Makefile b/debian/policy/Makefile
new file mode 100644
index 0000000..b5cf01b
--- /dev/null
+++ b/debian/policy/Makefile
@@ -0,0 +1,31 @@
+
+NULL =
+INSTALL_STUFF = \
+ vim-policy.html/ \
+ vim-policy.txt \
+ $(NULL)
+
+all: html text
+
+# to be used on alioth for updating policy linked by pkg-vim project page
+install: all
+ cp -r $(INSTALL_STUFF) ~/pkg-vim/htdocs/
+
+html: vim-policy.html/index.html
+text: vim-policy.txt
+
+export LC_ALL=C.UTF-8
+
+vim-policy.html/index.html: vim-policy.xml *.xml
+ docbook2html $< -o $(dir $@)
+vim-policy.txt: vim-policy.xml *.xml
+ docbook2txt $<
+
+clean:
+ $(RM) -rf $(INSTALL_STUFF)
+
+upload_web: all
+ scp -rC $(INSTALL_STUFF) alioth.debian.org:/srv/home/groups/pkg-vim/htdocs/
+
+.PHONY: html text upload_web
+