summaryrefslogtreecommitdiffstats
path: root/src/tee/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/tee/Makefile')
-rw-r--r--src/tee/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/tee/Makefile b/src/tee/Makefile
new file mode 100644
index 0000000..7419913
--- /dev/null
+++ b/src/tee/Makefile
@@ -0,0 +1,21 @@
+# A very (if not the most) simplistic Makefile for MS-Windows and OS/2
+
+CC=gcc
+CFLAGS=-O2 -fno-strength-reduce
+
+ifneq (sh.exe, $(SHELL))
+DEL = rm
+else
+DEL = del
+endif
+
+tee.exe: tee.o
+ $(CC) $(CFLAGS) -s -o $@ $<
+
+tee.o: tee.c
+ $(CC) $(CFLAGS) -c $<
+
+clean:
+ - $(DEL) tee.o
+ - $(DEL) tee.exe
+