summaryrefslogtreecommitdiffstats
path: root/debian/checkapi
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 18:37:15 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 18:37:15 +0000
commit55ad72d44a94298a96b8f05488ca5ed97ef04736 (patch)
tree8aaa712c1d8b8d191b77a7eef4dc42c770e3b3d0 /debian/checkapi
parentAdding upstream version 1:9.11.5.P4+dfsg. (diff)
downloadbind9-55ad72d44a94298a96b8f05488ca5ed97ef04736.tar.xz
bind9-55ad72d44a94298a96b8f05488ca5ed97ef04736.zip
Adding debian version 1:9.11.5.P4+dfsg-5.1+deb10u7.debian/1%9.11.5.P4+dfsg-5.1+deb10u7debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/checkapi')
-rwxr-xr-xdebian/checkapi11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/checkapi b/debian/checkapi
new file mode 100755
index 0000000..52eec8e
--- /dev/null
+++ b/debian/checkapi
@@ -0,0 +1,11 @@
+#!/bin/sh
+ret=0
+for LIB in bind9 dns irs isc lwres isccc isccfg; do
+ OLD_SOVERSION=$(sed -ne "s/Package: lib$LIB[-]*\([0-9]*\)$/\1/p" debian/control)
+ NEW_SOVERSION=$(debian/getapi "${LIB}")
+ if [ "$OLD_SOVERSION" -ne "$NEW_SOVERSION" ]; then
+ echo "ERROR: SONAME of lib$LIB has changed from lib$LIB.so.$OLD_SOVERSION to lib$1.so.$NEW_SOVERSION"
+ ret=1
+ fi
+done
+exit $ret