summaryrefslogtreecommitdiffstats
path: root/debian/checkapi
diff options
context:
space:
mode:
Diffstat (limited to 'debian/checkapi')
-rwxr-xr-xdebian/checkapi11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/checkapi b/debian/checkapi
new file mode 100755
index 0000000..52eec8e
--- /dev/null
+++ b/debian/checkapi
@@ -0,0 +1,11 @@
+#!/bin/sh
+ret=0
+for LIB in bind9 dns irs isc lwres isccc isccfg; do
+ OLD_SOVERSION=$(sed -ne "s/Package: lib$LIB[-]*\([0-9]*\)$/\1/p" debian/control)
+ NEW_SOVERSION=$(debian/getapi "${LIB}")
+ if [ "$OLD_SOVERSION" -ne "$NEW_SOVERSION" ]; then
+ echo "ERROR: SONAME of lib$LIB has changed from lib$LIB.so.$OLD_SOVERSION to lib$1.so.$NEW_SOVERSION"
+ ret=1
+ fi
+done
+exit $ret