summaryrefslogtreecommitdiffstats
path: root/doc/arm/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'doc/arm/Makefile.in')
-rw-r--r--doc/arm/Makefile.in66
1 files changed, 66 insertions, 0 deletions
diff --git a/doc/arm/Makefile.in b/doc/arm/Makefile.in
new file mode 100644
index 0000000..c79f5ab
--- /dev/null
+++ b/doc/arm/Makefile.in
@@ -0,0 +1,66 @@
+# Copyright (C) Internet Systems Consortium, Inc. ("ISC")
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# See the COPYRIGHT file distributed with this work for additional
+# information regarding copyright ownership.
+
+srcdir = @srcdir@
+VPATH = @srcdir@
+top_srcdir = @top_srcdir@
+
+@BIND9_MAKE_RULES@
+
+MANOBJS = Bv9ARM.html notes.html
+
+TXTOBJS = notes.txt
+
+PDFOBJS = Bv9ARM.pdf notes.pdf
+
+doc man:: ${MANOBJS} ${TXTOBJS} ${PDFOBJS}
+
+clean::
+ rm -f Bv9ARM.aux Bv9ARM.brf Bv9ARM.glo Bv9ARM.idx Bv9ARM.toc
+ rm -f Bv9ARM.log Bv9ARM.out
+ rm -f notes.aux notes.brf notes.glo notes.idx notes.toc
+ rm -f notes.log notes.out
+
+docclean manclean maintainer-clean:: clean
+ rm -f *.html ${PDFOBJS}
+
+maintainer-clean distclean::
+ rm -f releaseinfo.xml
+ rm -f pkgversion.xml
+ rm -f noteversion.xml
+
+# use xmllint to process include
+notes.html: notes-wrapper.xml notes.xml releaseinfo.xml pkgversion.xml noteversion.xml
+ expand notes-wrapper.xml | ${XMLLINT} --xinclude - | \
+ ${XSLTPROC} --stringparam generate.toc "" ../xsl/isc-notes-html.xsl - > notes.html
+
+notes.pdf: notes-wrapper.xml notes.xml releaseinfo.xml pkgversion.xml noteversion.xml
+ ${XSLTPROC} ${top_srcdir}/doc/xsl/pre-latex.xsl notes-wrapper.xml | \
+ ${DBLATEX} -c notes.conf -Pdoc.layout="mainmatter" -o notes.pdf -
+
+notes.txt: notes.html
+ ${W3M} -dump -cols 75 -O ascii -T text/html < notes.html | \
+ sed 's/ *$$//' | \
+ sed -e :a -e '/^\n*$$/{$$d;N;};/\n$$/ba' > notes.txt
+
+# use xmllint to process include
+Bv9ARM.html: Bv9ARM-book.xml releaseinfo.xml pkgversion.xml noteversion.xml
+ expand Bv9ARM-book.xml | ${XMLLINT} --xinclude - | \
+ ${XSLTPROC} --stringparam root.filename Bv9ARM \
+ ${top_srcdir}/doc/xsl/isc-docbook-chunk.xsl -
+
+# use xmllint to process include
+Bv9ARM-all.html: Bv9ARM-book.xml releaseinfo.xml pkgversion.xml noteversion.xml
+ expand Bv9ARM-book.xml | ${XMLLINT} --xinclude - |\
+ ${XSLTPROC} -o Bv9ARM-all.html ../xsl/isc-docbook-html.xsl -
+
+Bv9ARM.pdf: Bv9ARM-book.xml releaseinfo.xml pkgversion.xml noteversion.xml
+ expand Bv9ARM-book.xml | \
+ ${XSLTPROC} ${top_srcdir}/doc/xsl/pre-latex.xsl - | \
+ ${DBLATEX} -c Bv9ARM.conf -o Bv9ARM.pdf -