summaryrefslogtreecommitdiffstats
path: root/scripts/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/setup.py')
-rwxr-xr-xscripts/setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/scripts/setup.py b/scripts/setup.py
new file mode 100755
index 0000000..5908616
--- /dev/null
+++ b/scripts/setup.py
@@ -0,0 +1,29 @@
+#!/usr/bin/python3
+
+import os
+import re
+
+from setuptools import setup
+
+from devscripts.test import SCRIPTS
+
+
+def get_version():
+ # look/set what version we have
+ changelog = "../debian/changelog"
+ if os.path.exists(changelog):
+ head = open(changelog, encoding="utf8").readline()
+ match = re.compile(r".*\((.*)\).*").match(head)
+ if match:
+ return match.group(1)
+ raise Exception("Failed to determine version from debian/changelog")
+
+
+if __name__ == '__main__':
+ setup(
+ name='devscripts',
+ version=get_version(),
+ scripts=SCRIPTS,
+ packages=['devscripts', 'devscripts/test'],
+ test_suite='devscripts.test',
+ )