summaryrefslogtreecommitdiffstats
path: root/dpkg-deb/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:45:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:45:20 +0000
commit9a08cbfcc1ef900a04580f35afe2a4592d7d6030 (patch)
tree004cc7027bca2f2c0bcb5806527c8e0c48df2d6e /dpkg-deb/Makefile.am
parentInitial commit. (diff)
downloaddpkg-upstream.tar.xz
dpkg-upstream.zip
Adding upstream version 1.19.8.upstream/1.19.8upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dpkg-deb/Makefile.am')
-rw-r--r--dpkg-deb/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/dpkg-deb/Makefile.am b/dpkg-deb/Makefile.am
new file mode 100644
index 0000000..02d79ed
--- /dev/null
+++ b/dpkg-deb/Makefile.am
@@ -0,0 +1,25 @@
+## Process this file with automake to produce Makefile.in
+
+localedir = $(datadir)/locale
+AM_CPPFLAGS = \
+ -DLOCALEDIR=\"$(localedir)\" \
+ -idirafter $(top_srcdir)/lib/compat \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/lib
+
+
+bin_PROGRAMS = dpkg-deb
+
+dpkg_deb_SOURCES = \
+ dpkg-deb.h \
+ build.c \
+ extract.c \
+ info.c \
+ main.c
+
+dpkg_deb_LDADD = \
+ ../lib/dpkg/libdpkg.la \
+ $(LIBINTL) \
+ $(Z_LIBS) \
+ $(LZMA_LIBS) \
+ $(BZ2_LIBS)