summaryrefslogtreecommitdiffstats
path: root/modules/hints/hints.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:55:53 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:55:53 +0000
commit3d0386f27ca66379acf50199e1d1298386eeeeb8 (patch)
treef87bd4a126b3a843858eb447e8fd5893c3ee3882 /modules/hints/hints.mk
parentInitial commit. (diff)
downloadknot-resolver-3d0386f27ca66379acf50199e1d1298386eeeeb8.tar.xz
knot-resolver-3d0386f27ca66379acf50199e1d1298386eeeeb8.zip
Adding upstream version 3.2.1.upstream/3.2.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'modules/hints/hints.mk')
-rw-r--r--modules/hints/hints.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/modules/hints/hints.mk b/modules/hints/hints.mk
new file mode 100644
index 0000000..7613c18
--- /dev/null
+++ b/modules/hints/hints.mk
@@ -0,0 +1,8 @@
+hints_CFLAGS := -fPIC
+# We use a symbol that's not in libkres but the daemon.
+# On darwin this isn't accepted by default.
+hints_LDFLAGS := -Wl,-undefined -Wl,dynamic_lookup
+hints_SOURCES := modules/hints/hints.c
+hints_DEPEND := $(libkres)
+hints_LIBS := $(contrib_TARGET) $(libkres_TARGET) $(libkres_LIBS)
+$(call make_c_module,hints)