summaryrefslogtreecommitdiffstats
path: root/arch/x86/events/amd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/x86/events/amd/Makefile')
-rw-r--r--arch/x86/events/amd/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/arch/x86/events/amd/Makefile b/arch/x86/events/amd/Makefile
new file mode 100644
index 000000000..fe8795a67
--- /dev/null
+++ b/arch/x86/events/amd/Makefile
@@ -0,0 +1,8 @@
+# SPDX-License-Identifier: GPL-2.0
+obj-$(CONFIG_CPU_SUP_AMD) += core.o uncore.o
+obj-$(CONFIG_PERF_EVENTS_AMD_POWER) += power.o
+obj-$(CONFIG_X86_LOCAL_APIC) += ibs.o
+ifdef CONFIG_AMD_IOMMU
+obj-$(CONFIG_CPU_SUP_AMD) += iommu.o
+endif
+