summaryrefslogtreecommitdiffstats
path: root/drivers/vhost/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/vhost/Makefile')
-rw-r--r--drivers/vhost/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/drivers/vhost/Makefile b/drivers/vhost/Makefile
new file mode 100644
index 000000000..6c6df24f7
--- /dev/null
+++ b/drivers/vhost/Makefile
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-2.0
+obj-$(CONFIG_VHOST_NET) += vhost_net.o
+vhost_net-y := net.o
+
+obj-$(CONFIG_VHOST_SCSI) += vhost_scsi.o
+vhost_scsi-y := scsi.o
+
+obj-$(CONFIG_VHOST_VSOCK) += vhost_vsock.o
+vhost_vsock-y := vsock.o
+
+obj-$(CONFIG_VHOST_RING) += vringh.o
+
+obj-$(CONFIG_VHOST) += vhost.o