summaryrefslogtreecommitdiffstats
path: root/net/tipc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/tipc/Makefile')
-rw-r--r--net/tipc/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/net/tipc/Makefile b/net/tipc/Makefile
new file mode 100644
index 000000000..aca168f2a
--- /dev/null
+++ b/net/tipc/Makefile
@@ -0,0 +1,21 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the Linux TIPC layer
+#
+
+obj-$(CONFIG_TIPC) := tipc.o
+
+tipc-y += addr.o bcast.o bearer.o \
+ core.o link.o discover.o msg.o \
+ name_distr.o subscr.o monitor.o name_table.o net.o \
+ netlink.o netlink_compat.o node.o socket.o eth_media.o \
+ topsrv.o socket.o group.o
+
+tipc-$(CONFIG_TIPC_MEDIA_UDP) += udp_media.o
+tipc-$(CONFIG_TIPC_MEDIA_IB) += ib_media.o
+tipc-$(CONFIG_SYSCTL) += sysctl.o
+
+
+obj-$(CONFIG_TIPC_DIAG) += diag.o
+
+tipc_diag-y := diag.o