summaryrefslogtreecommitdiffstats
path: root/sound/hda/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sound/hda/Makefile')
-rw-r--r--sound/hda/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/sound/hda/Makefile b/sound/hda/Makefile
new file mode 100644
index 000000000..2160202e2
--- /dev/null
+++ b/sound/hda/Makefile
@@ -0,0 +1,15 @@
+# SPDX-License-Identifier: GPL-2.0
+snd-hda-core-objs := hda_bus_type.o hdac_bus.o hdac_device.o hdac_sysfs.o \
+ hdac_regmap.o hdac_controller.o hdac_stream.o array.o hdmi_chmap.o
+
+snd-hda-core-objs += trace.o
+CFLAGS_trace.o := -I$(src)
+
+# for sync with i915 gfx driver
+snd-hda-core-$(CONFIG_SND_HDA_COMPONENT) += hdac_component.o
+snd-hda-core-$(CONFIG_SND_HDA_I915) += hdac_i915.o
+
+obj-$(CONFIG_SND_HDA_CORE) += snd-hda-core.o
+
+#extended hda
+obj-$(CONFIG_SND_HDA_EXT_CORE) += ext/