summaryrefslogtreecommitdiffstats
path: root/tools/testing/selftests/proc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/testing/selftests/proc/Makefile')
-rw-r--r--tools/testing/selftests/proc/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/tools/testing/selftests/proc/Makefile b/tools/testing/selftests/proc/Makefile
new file mode 100644
index 000000000..434d033ee
--- /dev/null
+++ b/tools/testing/selftests/proc/Makefile
@@ -0,0 +1,20 @@
+CFLAGS += -Wall -O2 -Wno-unused-function
+CFLAGS += -D_GNU_SOURCE
+
+TEST_GEN_PROGS :=
+TEST_GEN_PROGS += fd-001-lookup
+TEST_GEN_PROGS += fd-002-posix-eq
+TEST_GEN_PROGS += fd-003-kthread
+TEST_GEN_PROGS += proc-loadavg-001
+TEST_GEN_PROGS += proc-self-map-files-001
+TEST_GEN_PROGS += proc-self-map-files-002
+TEST_GEN_PROGS += proc-self-syscall
+TEST_GEN_PROGS += proc-self-wchan
+TEST_GEN_PROGS += proc-uptime-001
+TEST_GEN_PROGS += proc-uptime-002
+TEST_GEN_PROGS += read
+TEST_GEN_PROGS += self
+TEST_GEN_PROGS += setns-dcache
+TEST_GEN_PROGS += thread-self
+
+include ../lib.mk