summaryrefslogtreecommitdiffstats
path: root/web/api/queries/max
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 01:22:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 01:22:31 +0000
commit8d4f58e49b9dc7d3545651023a36729de773ad86 (patch)
tree7bc7be4a8e9e298daa1349348400aa2a653866f2 /web/api/queries/max
parentInitial commit. (diff)
downloadnetdata-8d4f58e49b9dc7d3545651023a36729de773ad86.tar.xz
netdata-8d4f58e49b9dc7d3545651023a36729de773ad86.zip
Adding upstream version 1.12.0.upstream/1.12.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'web/api/queries/max')
-rw-r--r--web/api/queries/max/Makefile.am8
-rw-r--r--web/api/queries/max/README.md33
-rw-r--r--web/api/queries/max/max.c60
-rw-r--r--web/api/queries/max/max.h15
4 files changed, 116 insertions, 0 deletions
diff --git a/web/api/queries/max/Makefile.am b/web/api/queries/max/Makefile.am
new file mode 100644
index 0000000..19554be
--- /dev/null
+++ b/web/api/queries/max/Makefile.am
@@ -0,0 +1,8 @@
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+AUTOMAKE_OPTIONS = subdir-objects
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+
+dist_noinst_DATA = \
+ README.md \
+ $(NULL)
diff --git a/web/api/queries/max/README.md b/web/api/queries/max/README.md
new file mode 100644
index 0000000..34dff02
--- /dev/null
+++ b/web/api/queries/max/README.md
@@ -0,0 +1,33 @@
+# Max
+
+This module finds the max value in the time-frame given.
+
+## how to use
+
+Use it in alarms like this:
+
+```
+ alarm: my_alarm
+ on: my_chart
+lookup: max -1m unaligned of my_dimension
+ warn: $this > 1000
+```
+
+`max` does not change the units. For example, if the chart units is `requests/sec`, the result
+will be again expressed in the same units.
+
+It can also be used in APIs and badges as `&group=max` in the URL.
+
+## Examples
+
+Examining last 1 minute `successful` web server responses:
+
+- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=min&after=-60&label=min)
+- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=average&after=-60&label=average)
+- ![](https://registry.my-netdata.io/api/v1/badge.svg?chart=web_log_nginx.response_statuses&options=unaligned&dimensions=success&group=max&after=-60&label=max&value_color=orange)
+
+## References
+
+- [https://en.wikipedia.org/wiki/Sample_maximum_and_minimum](https://en.wikipedia.org/wiki/Sample_maximum_and_minimum).
+
+[![analytics](https://www.google-analytics.com/collect?v=1&aip=1&t=pageview&_s=1&ds=github&dr=https%3A%2F%2Fgithub.com%2Fnetdata%2Fnetdata&dl=https%3A%2F%2Fmy-netdata.io%2Fgithub%2Fweb%2Fapi%2Fqueries%2Fmax%2FREADME&_u=MAC~&cid=5792dfd7-8dc4-476b-af31-da2fdb9f93d2&tid=UA-64295674-3)]()
diff --git a/web/api/queries/max/max.c b/web/api/queries/max/max.c
new file mode 100644
index 0000000..a4be36a
--- /dev/null
+++ b/web/api/queries/max/max.c
@@ -0,0 +1,60 @@
+// SPDX-License-Identifier: GPL-3.0-or-later
+
+#include "max.h"
+
+// ----------------------------------------------------------------------------
+// max
+
+struct grouping_max {
+ calculated_number max;
+ size_t count;
+};
+
+void *grouping_create_max(RRDR *r) {
+ (void)r;
+ return callocz(1, sizeof(struct grouping_max));
+}
+
+// resets when switches dimensions
+// so, clear everything to restart
+void grouping_reset_max(RRDR *r) {
+ struct grouping_max *g = (struct grouping_max *)r->internal.grouping_data;
+ g->max = 0;
+ g->count = 0;
+}
+
+void grouping_free_max(RRDR *r) {
+ freez(r->internal.grouping_data);
+ r->internal.grouping_data = NULL;
+}
+
+void grouping_add_max(RRDR *r, calculated_number value) {
+ if(!isnan(value)) {
+ struct grouping_max *g = (struct grouping_max *)r->internal.grouping_data;
+
+ if(!g->count || calculated_number_fabs(value) > calculated_number_fabs(g->max)) {
+ g->max = value;
+ g->count++;
+ }
+ }
+}
+
+calculated_number grouping_flush_max(RRDR *r, RRDR_VALUE_FLAGS *rrdr_value_options_ptr) {
+ struct grouping_max *g = (struct grouping_max *)r->internal.grouping_data;
+
+ calculated_number value;
+
+ if(unlikely(!g->count)) {
+ value = 0.0;
+ *rrdr_value_options_ptr |= RRDR_VALUE_EMPTY;
+ }
+ else {
+ value = g->max;
+ }
+
+ g->max = 0.0;
+ g->count = 0;
+
+ return value;
+}
+
diff --git a/web/api/queries/max/max.h b/web/api/queries/max/max.h
new file mode 100644
index 0000000..d839fe3
--- /dev/null
+++ b/web/api/queries/max/max.h
@@ -0,0 +1,15 @@
+// SPDX-License-Identifier: GPL-3.0-or-later
+
+#ifndef NETDATA_API_QUERY_MAX_H
+#define NETDATA_API_QUERY_MAX_H
+
+#include "../query.h"
+#include "../rrdr.h"
+
+extern void *grouping_create_max(RRDR *r);
+extern void grouping_reset_max(RRDR *r);
+extern void grouping_free_max(RRDR *r);
+extern void grouping_add_max(RRDR *r, calculated_number value);
+extern calculated_number grouping_flush_max(RRDR *r, RRDR_VALUE_FLAGS *rrdr_value_options_ptr);
+
+#endif //NETDATA_API_QUERY_MAX_H