summaryrefslogtreecommitdiffstats
path: root/dh_make_pgxs/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'dh_make_pgxs/debian/rules')
-rwxr-xr-xdh_make_pgxs/debian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/dh_make_pgxs/debian/rules b/dh_make_pgxs/debian/rules
new file mode 100755
index 0000000..7b28bd8
--- /dev/null
+++ b/dh_make_pgxs/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+include /usr/share/postgresql-common/pgxs_debian_control.mk
+
+override_dh_auto_build:
+ +pg_buildext build build-%v
+
+override_dh_auto_test:
+ # nothing to do here, see debian/tests/* instead
+
+override_dh_auto_install:
+ +pg_buildext install build-%v postgresql-%v-@EXTNAME@
+
+override_dh_installdocs:
+ dh_installdocs --all README.*
+
+override_dh_auto_clean:
+ +pg_buildext clean build-%v
+
+%:
+ dh $@