summaryrefslogtreecommitdiffstats
path: root/src/VBox/Disassembler/Makefile.kmk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 03:01:46 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 03:01:46 +0000
commitf8fe689a81f906d1b91bb3220acde2a4ecb14c5b (patch)
tree26484e9d7e2c67806c2d1760196ff01aaa858e8c /src/VBox/Disassembler/Makefile.kmk
parentInitial commit. (diff)
downloadvirtualbox-f8fe689a81f906d1b91bb3220acde2a4ecb14c5b.tar.xz
virtualbox-f8fe689a81f906d1b91bb3220acde2a4ecb14c5b.zip
Adding upstream version 6.0.4-dfsg.upstream/6.0.4-dfsgupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/VBox/Disassembler/Makefile.kmk')
-rw-r--r--src/VBox/Disassembler/Makefile.kmk81
1 files changed, 81 insertions, 0 deletions
diff --git a/src/VBox/Disassembler/Makefile.kmk b/src/VBox/Disassembler/Makefile.kmk
new file mode 100644
index 00000000..0305861e
--- /dev/null
+++ b/src/VBox/Disassembler/Makefile.kmk
@@ -0,0 +1,81 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-Makefile for the VBox Disassembler.
+#
+
+#
+# Copyright (C) 2006-2019 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+
+SUB_DEPTH = ../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+# include the sub-makefile first.
+if defined(VBOX_WITH_TESTCASES) && !defined(VBOX_ONLY_VALIDATIONKIT)
+ include $(PATH_SUB_CURRENT)/testcase/Makefile.kmk
+endif
+
+
+LIBRARIES += DisasmR3
+DisasmR3_TEMPLATE = VBOXR3
+DisasmR3_DEFS = IN_DIS
+DisasmR3_SOURCES = \
+ Disasm.cpp \
+ DisasmCore.cpp \
+ DisasmReg.cpp \
+ DisasmTables.cpp \
+ DisasmTablesX64.cpp \
+ DisasmFormatBytes.cpp \
+ DisasmFormatYasm.cpp
+
+LIBRARIES += DisasmR3Static
+DisasmR3Static_TEMPLATE = VBoxR3Static
+DisasmR3Static_EXTENDS = DisasmR3
+
+ifndef VBOX_ONLY_VALIDATIONKIT
+
+ LIBRARIES += DisasmBldProg
+ DisasmBldProg_TEMPLATE = VBoxAdvBldProg
+ DisasmBldProg_EXTENDS = DisasmR3
+
+ LIBRARIES += DisasmCoreR3
+ DisasmCoreR3_TEMPLATE = VBOXR3
+ DisasmCoreR3_DEFS = IN_DIS DIS_CORE_ONLY
+ DisasmCoreR3_SOURCES = \
+ DisasmCore.cpp \
+ DisasmReg.cpp \
+ DisasmTables.cpp \
+ DisasmTablesX64.cpp
+
+ ifdef VBOX_WITH_RAW_MODE
+ LIBRARIES += DisasmRC
+ DisasmRC_TEMPLATE = VBoxRc
+ DisasmRC_DEFS = IN_DIS IN_RT_RC DIS_CORE_ONLY
+ DisasmRC_SOURCES = \
+ DisasmCore.cpp \
+ DisasmReg.cpp \
+ DisasmTables.cpp \
+ DisasmTablesX64.cpp
+ endif # VBOX_WITH_RAW_MODE
+
+ LIBRARIES += DisasmR0
+ DisasmR0_TEMPLATE = VBoxR0
+ DisasmR0_DEFS = IN_DIS IN_RT_R0 DIS_CORE_ONLY
+ DisasmR0_SOURCES = \
+ DisasmCore.cpp \
+ DisasmReg.cpp \
+ DisasmTables.cpp \
+ DisasmTablesX64.cpp
+
+endif # !VBOX_ONLY_VALIDATIONKIT
+
+include $(FILE_KBUILD_SUB_FOOTER)
+