summaryrefslogtreecommitdiffstats
path: root/src/VBox/HostDrivers/freebsd
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 03:01:46 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 03:01:46 +0000
commitf8fe689a81f906d1b91bb3220acde2a4ecb14c5b (patch)
tree26484e9d7e2c67806c2d1760196ff01aaa858e8c /src/VBox/HostDrivers/freebsd
parentInitial commit. (diff)
downloadvirtualbox-f8fe689a81f906d1b91bb3220acde2a4ecb14c5b.tar.xz
virtualbox-f8fe689a81f906d1b91bb3220acde2a4ecb14c5b.zip
Adding upstream version 6.0.4-dfsg.upstream/6.0.4-dfsgupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/VBox/HostDrivers/freebsd')
-rw-r--r--src/VBox/HostDrivers/freebsd/Makefile84
-rw-r--r--src/VBox/HostDrivers/freebsd/Makefile.kmk35
2 files changed, 119 insertions, 0 deletions
diff --git a/src/VBox/HostDrivers/freebsd/Makefile b/src/VBox/HostDrivers/freebsd/Makefile
new file mode 100644
index 00000000..d7feacdf
--- /dev/null
+++ b/src/VBox/HostDrivers/freebsd/Makefile
@@ -0,0 +1,84 @@
+#
+# Makefile for the VirtualBox FreeBSD Host Drivers.
+#
+
+#
+# Copyright (C) 2008-2019 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+# The contents of this file may alternatively be used under the terms
+# of the Common Development and Distribution License Version 1.0
+# (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+# VirtualBox OSE distribution, in which case the provisions of the
+# CDDL are applicable instead of those of the GPL.
+#
+# You may elect to license modified versions of this file under the
+# terms and conditions of either the GPL or the CDDL or both.
+#
+
+KBUILD_VERBOSE =
+
+all:
+ @echo "=== Building 'vboxdrv' module ==="
+ @$(MAKE) KBUILD_VERBOSE=$(KBUILD_VERBOSE) -C vboxdrv
+ @cp vboxdrv/vboxdrv.ko .
+ @echo
+ @if [ -d vboxnetflt ]; then \
+ if [ -f vboxdrv/Module.symvers ]; then \
+ cp vboxdrv/Module.symvers vboxnetflt; \
+ fi; \
+ echo "=== Building 'vboxnetflt' module ==="; \
+ $(MAKE) KBUILD_VERBOSE=$(KBUILD_VERBOSE) -C vboxnetflt; \
+ cp vboxnetflt/vboxnetflt.ko .; \
+ echo; \
+ fi
+ @if [ -d vboxnetadp ]; then \
+ if [ -f vboxdrv/Module.symvers ]; then \
+ cp vboxdrv/Module.symvers vboxnetadp; \
+ fi; \
+ echo "=== Building 'vboxnetadp' module ==="; \
+ $(MAKE) KBUILD_VERBOSE=$(KBUILD_VERBOSE) -C vboxnetadp; \
+ cp vboxnetadp/vboxnetadp.ko .; \
+ echo; \
+ fi
+
+
+install:
+ @$(MAKE) KBUILD_VERBOSE=$(KBUILD_VERBOSE) -C vboxdrv install
+ @if [ -d vboxnetflt ]; then \
+ $(MAKE) KBUILD_VERBOSE=$(KBUILD_VERBOSE) -C vboxnetflt install; \
+ fi
+ @if [ -d vboxnetadp ]; then \
+ $(MAKE) KBUILD_VERBOSE=$(KBUILD_VERBOSE) -C vboxnetadp install; \
+ fi
+
+clean:
+ @$(MAKE) -C vboxdrv clean
+ @if [ -d vboxnetflt ]; then \
+ $(MAKE) -C vboxnetflt clean; \
+ fi
+ @if [ -d vboxnetadp ]; then \
+ $(MAKE) -C vboxnetadp clean; \
+ fi
+ rm -f vboxdrv.ko vboxnetflt.ko vboxnetadp.ko
+
+load:
+ @for module in vboxnetadp vboxnetflt vboxdrv; do \
+ if kldstat -n "$$module" >/dev/null; then \
+ echo "Removing previously installed $$module module"; \
+ /sbin/kldunload $$module; \
+ fi; \
+ done
+ @for module in vboxdrv vboxnetflt vboxnetadp; do \
+ if test -f $$module.ko; then \
+ echo "Installing $$module module"; \
+ /sbin/kldload ./$$module.ko; \
+ fi; \
+ done
diff --git a/src/VBox/HostDrivers/freebsd/Makefile.kmk b/src/VBox/HostDrivers/freebsd/Makefile.kmk
new file mode 100644
index 00000000..c9903851
--- /dev/null
+++ b/src/VBox/HostDrivers/freebsd/Makefile.kmk
@@ -0,0 +1,35 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-makefile for the FreeBSD host driver helper scripts.
+#
+
+#
+# Copyright (C) 2006-2019 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+# The contents of this file may alternatively be used under the terms
+# of the Common Development and Distribution License Version 1.0
+# (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+# VirtualBox OSE distribution, in which case the provisions of the
+# CDDL are applicable instead of those of the GPL.
+#
+# You may elect to license modified versions of this file under the
+# terms and conditions of either the GPL or the CDDL or both.
+#
+
+SUB_DEPTH = ../../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+INSTALLS += HostDrivers-scripts
+HostDrivers-scripts_INST = bin/src/
+HostDrivers-scripts_SOURCES = Makefile
+
+include $(FILE_KBUILD_SUB_FOOTER)
+