summaryrefslogtreecommitdiffstats
path: root/src/VBox/NetworkServices/Makefile.kmk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 03:01:46 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 03:01:46 +0000
commitf8fe689a81f906d1b91bb3220acde2a4ecb14c5b (patch)
tree26484e9d7e2c67806c2d1760196ff01aaa858e8c /src/VBox/NetworkServices/Makefile.kmk
parentInitial commit. (diff)
downloadvirtualbox-f8fe689a81f906d1b91bb3220acde2a4ecb14c5b.tar.xz
virtualbox-f8fe689a81f906d1b91bb3220acde2a4ecb14c5b.zip
Adding upstream version 6.0.4-dfsg.upstream/6.0.4-dfsgupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/VBox/NetworkServices/Makefile.kmk')
-rw-r--r--src/VBox/NetworkServices/Makefile.kmk35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/VBox/NetworkServices/Makefile.kmk b/src/VBox/NetworkServices/Makefile.kmk
new file mode 100644
index 00000000..9885b9d7
--- /dev/null
+++ b/src/VBox/NetworkServices/Makefile.kmk
@@ -0,0 +1,35 @@
+# $Id: Makefile.kmk $
+## @file
+# Top-level makefile for the VBox Network Services.
+#
+
+#
+# Copyright (C) 2009-2019 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+
+SUB_DEPTH = ../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+# VBoxNetDHCP and VBoxNetNAT require COM/XPCOM
+ifdef VBOX_WITH_MAIN
+ # Include sub-makefiles.
+ ifndef VBOX_WITH_DHCPD
+ include $(PATH_SUB_CURRENT)/DHCP/Makefile.kmk
+ else
+ include $(PATH_SUB_CURRENT)/Dhcpd/Makefile.kmk
+ endif
+ ifdef VBOX_WITH_NAT_SERVICE
+ include $(PATH_SUB_CURRENT)/NAT/Makefile.kmk
+ endif
+endif
+
+include $(FILE_KBUILD_SUB_FOOTER)
+