summaryrefslogtreecommitdiffstats
path: root/src/apps/svnsync-vbox/Makefile.kmk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 03:01:46 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 03:01:46 +0000
commitf8fe689a81f906d1b91bb3220acde2a4ecb14c5b (patch)
tree26484e9d7e2c67806c2d1760196ff01aaa858e8c /src/apps/svnsync-vbox/Makefile.kmk
parentInitial commit. (diff)
downloadvirtualbox-f8fe689a81f906d1b91bb3220acde2a4ecb14c5b.tar.xz
virtualbox-f8fe689a81f906d1b91bb3220acde2a4ecb14c5b.zip
Adding upstream version 6.0.4-dfsg.upstream/6.0.4-dfsgupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/apps/svnsync-vbox/Makefile.kmk')
-rw-r--r--src/apps/svnsync-vbox/Makefile.kmk44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/apps/svnsync-vbox/Makefile.kmk b/src/apps/svnsync-vbox/Makefile.kmk
new file mode 100644
index 00000000..bb75d546
--- /dev/null
+++ b/src/apps/svnsync-vbox/Makefile.kmk
@@ -0,0 +1,44 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-Makefile for svnsync-vbox.
+#
+
+#
+# Copyright (C) 2006-2019 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+
+SUB_DEPTH = ../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+PROGRAMS += svnsync-vbox
+
+svnsync-vbox_TEMPLATE = VBOXR3EXE
+svnsync-vbox_SOURCES = main.c
+svnsync-vbox_INCS = \
+ /usr/include/subversion-1 \
+ /usr/include/apr-0
+svnsync-vbox_LIBS = \
+ svn_ra-1 \
+ svn_ra_dav-1 \
+ svn_ra_svn-1 \
+ svn_ra_local-1 \
+ svn_repos-1 \
+ svn_fs-1 \
+ svn_fs_base-1 \
+ svn_fs_fs-1 \
+ svn_delta-1 \
+ svn_subr-1 \
+ neon \
+ apr-0 \
+ aprutil-0
+
+include $(FILE_KBUILD_SUB_FOOTER)
+