summaryrefslogtreecommitdiffstats
path: root/src/VBox/Frontends/VBoxBalloonCtrl/Makefile.kmk
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/Frontends/VBoxBalloonCtrl/Makefile.kmk')
-rw-r--r--src/VBox/Frontends/VBoxBalloonCtrl/Makefile.kmk34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/VBox/Frontends/VBoxBalloonCtrl/Makefile.kmk b/src/VBox/Frontends/VBoxBalloonCtrl/Makefile.kmk
new file mode 100644
index 00000000..45c122ce
--- /dev/null
+++ b/src/VBox/Frontends/VBoxBalloonCtrl/Makefile.kmk
@@ -0,0 +1,34 @@
+# $Id: Makefile.kmk $
+## @file
+# VBoxBalloonCtrl - Memory balloon control.
+#
+
+#
+# Copyright (C) 2011-2019 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+
+SUB_DEPTH = ../../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+PROGRAMS += VBoxBalloonCtrl
+ VBoxBalloonCtrl_TEMPLATE = VBOXMAINCLIENTEXE
+ VBoxBalloonCtrl_DEFS += \
+ VBOX_WATCHDOG_GLOBAL_PERFCOL VBOX_BUILD_TARGET=\"$(KBUILD_TARGET).$(KBUILD_TARGET_ARCH)\"
+ VBoxBalloonCtrl_DEFS.win = _WIN32_WINNT=0x0500
+ VBoxBalloonCtrl_SOURCES = \
+ VBoxWatchdog.cpp \
+ VBoxWatchdogUtils.cpp \
+ VBoxModAPIMonitor.cpp \
+ VBoxModBallooning.cpp
+ VBoxBalloonCtrl_SOURCES.win = \
+ VBoxBalloonCtrl.rc
+
+include $(FILE_KBUILD_SUB_FOOTER)