summaryrefslogtreecommitdiffstats
path: root/src/VBox/HostDrivers/darwin
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/HostDrivers/darwin')
-rw-r--r--src/VBox/HostDrivers/darwin/Makefile.kmk37
-rw-r--r--src/VBox/HostDrivers/darwin/VBoxNetSend.h111
-rwxr-xr-xsrc/VBox/HostDrivers/darwin/loadall.sh39
3 files changed, 187 insertions, 0 deletions
diff --git a/src/VBox/HostDrivers/darwin/Makefile.kmk b/src/VBox/HostDrivers/darwin/Makefile.kmk
new file mode 100644
index 00000000..dd14070d
--- /dev/null
+++ b/src/VBox/HostDrivers/darwin/Makefile.kmk
@@ -0,0 +1,37 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-makefile for the darwin host driver helper scripts.
+#
+
+#
+# Copyright (C) 2010-2019 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+# The contents of this file may alternatively be used under the terms
+# of the Common Development and Distribution License Version 1.0
+# (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+# VirtualBox OSE distribution, in which case the provisions of the
+# CDDL are applicable instead of those of the GPL.
+#
+# You may elect to license modified versions of this file under the
+# terms and conditions of either the GPL or the CDDL or both.
+#
+
+SUB_DEPTH = ../../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+INSTALLS += HostDrivers-darwin-sh
+HostDrivers-darwin-sh_INST = $(INST_DIST)
+HostDrivers-darwin-sh_INSTTYPE = stage
+HostDrivers-darwin-sh_EXEC_SOURCES = \
+ loadall.sh
+
+include $(FILE_KBUILD_SUB_FOOTER)
+
diff --git a/src/VBox/HostDrivers/darwin/VBoxNetSend.h b/src/VBox/HostDrivers/darwin/VBoxNetSend.h
new file mode 100644
index 00000000..c4effc10
--- /dev/null
+++ b/src/VBox/HostDrivers/darwin/VBoxNetSend.h
@@ -0,0 +1,111 @@
+/* $Id: VBoxNetSend.h $ */
+/** @file
+ * A place to share code and definitions between VBoxNetAdp and VBoxNetFlt host drivers.
+ */
+
+/*
+ * Copyright (C) 2014-2019 Oracle Corporation
+ *
+ * This file is part of VirtualBox Open Source Edition (OSE), as
+ * available from http://www.virtualbox.org. This file is free software;
+ * you can redistribute it and/or modify it under the terms of the GNU
+ * General Public License (GPL) as published by the Free Software
+ * Foundation, in version 2 as it comes in the "COPYING" file of the
+ * VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+ * hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+ *
+ * The contents of this file may alternatively be used under the terms
+ * of the Common Development and Distribution License Version 1.0
+ * (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+ * VirtualBox OSE distribution, in which case the provisions of the
+ * CDDL are applicable instead of those of the GPL.
+ *
+ * You may elect to license modified versions of this file under the
+ * terms and conditions of either the GPL or the CDDL or both.
+ */
+
+/** @todo move this to src/VBox/HostDrivers/darwin as a .cpp file. */
+
+#ifndef VBOX_INCLUDED_SRC_darwin_VBoxNetSend_h
+#define VBOX_INCLUDED_SRC_darwin_VBoxNetSend_h
+#ifndef RT_WITHOUT_PRAGMA_ONCE
+# pragma once
+#endif
+
+#if defined(RT_OS_DARWIN)
+
+# include <iprt/err.h>
+# include <iprt/assert.h>
+# include <iprt/string.h>
+
+# include <sys/socket.h>
+# include <net/kpi_interface.h>
+RT_C_DECLS_BEGIN /* Buggy 10.4 headers, fixed in 10.5. */
+# include <sys/kpi_mbuf.h>
+RT_C_DECLS_END
+# include <net/if.h>
+
+RT_C_DECLS_BEGIN
+
+# if defined(IN_RING0)
+
+/**
+ * Constructs and submits a dummy packet to ifnet_input().
+ *
+ * This is a workaround for "stuck dock icon" issue. When the first packet goes
+ * through the interface DLIL grabs a reference to the thread that submits the
+ * packet and holds it until the interface is destroyed. By submitting this
+ * dummy we make DLIL grab the thread of a non-GUI process.
+ *
+ * Most of this function was copied from vboxNetFltDarwinMBufFromSG().
+ *
+ * @returns VBox status code.
+ * @param pIfNet The interface that will hold the reference to the calling
+ * thread. We submit dummy as if it was coming from this interface.
+ */
+DECLINLINE(int) VBoxNetSendDummy(ifnet_t pIfNet)
+{
+ int rc = VINF_SUCCESS;
+
+ size_t cbTotal = 50; /* No Ethernet header */
+ mbuf_how_t How = MBUF_WAITOK;
+ mbuf_t pPkt = NULL;
+ errno_t err = mbuf_allocpacket(How, cbTotal, NULL, &pPkt);
+ if (!err)
+ {
+ /* Skip zero sized memory buffers (paranoia). */
+ mbuf_t pCur = pPkt;
+ while (pCur && !mbuf_maxlen(pCur))
+ pCur = mbuf_next(pCur);
+ Assert(pCur);
+
+ /* Set the required packet header attributes. */
+ mbuf_pkthdr_setlen(pPkt, cbTotal);
+ mbuf_pkthdr_setheader(pPkt, mbuf_data(pCur));
+
+ mbuf_setlen(pCur, cbTotal);
+ memset(mbuf_data(pCur), 0, cbTotal);
+
+ mbuf_pkthdr_setrcvif(pPkt, pIfNet); /* will crash without this. */
+
+ err = ifnet_input(pIfNet, pPkt, NULL);
+ if (err)
+ {
+ rc = RTErrConvertFromErrno(err);
+ mbuf_freem(pPkt);
+ }
+ }
+ else
+ rc = RTErrConvertFromErrno(err);
+
+ return rc;
+}
+
+# endif /* IN_RING0 */
+
+RT_C_DECLS_END
+
+#endif /* RT_OS_DARWIN */
+
+#endif /* !VBOX_INCLUDED_SRC_darwin_VBoxNetSend_h */
+
diff --git a/src/VBox/HostDrivers/darwin/loadall.sh b/src/VBox/HostDrivers/darwin/loadall.sh
new file mode 100755
index 00000000..ada59dff
--- /dev/null
+++ b/src/VBox/HostDrivers/darwin/loadall.sh
@@ -0,0 +1,39 @@
+#!/bin/bash
+## @file
+# For development, loads all the host drivers.
+#
+
+#
+# Copyright (C) 2010-2019 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+# The contents of this file may alternatively be used under the terms
+# of the Common Development and Distribution License Version 1.0
+# (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+# VirtualBox OSE distribution, in which case the provisions of the
+# CDDL are applicable instead of those of the GPL.
+#
+# You may elect to license modified versions of this file under the
+# terms and conditions of either the GPL or the CDDL or both.
+#
+
+MY_DIR=`dirname "$0"`
+MY_DIR=`cd "${MY_DIR}" && pwd`
+if [ ! -d "${MY_DIR}" ]; then
+ echo "Cannot find ${MY_DIR} or it's not a directory..."
+ exit 1;
+fi
+
+set -e
+"${MY_DIR}/load.sh" "$*"
+"${MY_DIR}/loadusb.sh" "$*"
+"${MY_DIR}/loadnetflt.sh" "$*"
+"${MY_DIR}/loadnetadp.sh" "$*"
+