summaryrefslogtreecommitdiffstats
path: root/src/VBox/Installer/win/MsiHack/Makefile.kmk
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/Installer/win/MsiHack/Makefile.kmk')
-rw-r--r--src/VBox/Installer/win/MsiHack/Makefile.kmk42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/VBox/Installer/win/MsiHack/Makefile.kmk b/src/VBox/Installer/win/MsiHack/Makefile.kmk
new file mode 100644
index 00000000..91b6127d
--- /dev/null
+++ b/src/VBox/Installer/win/MsiHack/Makefile.kmk
@@ -0,0 +1,42 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-Makefile for the MsiHack.dll and MsiHackExtension.dll experiment.
+#
+
+#
+# Copyright (C) 2016-2019 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+
+SUB_DEPTH = ../../../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+DLLS += MsiHack
+MsiHack_TEMPLATE = VBOXR3STATIC
+MsiHack_BLD_TRG_ARCH = x86
+MsiHack_SOURCES = MsiHack.cpp
+
+ifndef windir
+ windir = C:/Windows
+endif
+VBOX_DOT_NET_COMPILER = $(firstword $(rsort $(wildcard $(windir)/Microsoft.NET/Framework/*/csc.exe)) csc.exe)
+
+OTHERS += $(MsiHack_0_OUTDIR)/MsiHackExtension.dll
+$$(MsiHack_0_OUTDIR)/MsiHackExtension.dll: $(PATH_SUB_CURRENT)/MsiHackExtension.cs $(MAKEFILE) | $$(dir $$@)
+ $(VBOX_DOT_NET_COMPILER) /nologo \
+ /out:$@ \
+ /target:library \
+ /reference:$(VBOX_PATH_WIX)/wix.dll \
+ $(subst /,\\,$<)
+
+MsiHackExtension.dll: $$(MsiHack_0_OUTDIR)/MsiHackExtension.dll
+
+include $(FILE_KBUILD_SUB_FOOTER)
+