summaryrefslogtreecommitdiffstats
path: root/src/VBox/Installer/win/StubBld/Makefile.kmk
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/Installer/win/StubBld/Makefile.kmk')
-rw-r--r--src/VBox/Installer/win/StubBld/Makefile.kmk28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/VBox/Installer/win/StubBld/Makefile.kmk b/src/VBox/Installer/win/StubBld/Makefile.kmk
new file mode 100644
index 00000000..3966e20a
--- /dev/null
+++ b/src/VBox/Installer/win/StubBld/Makefile.kmk
@@ -0,0 +1,28 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-Makefile for the stub builder.
+#
+
+#
+# Copyright (C) 2009-2019 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+
+SUB_DEPTH = ../../../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+# This is only used in the 32-bit build (see ../Stub/Makefile.kmk).
+PROGRAMS.x86 += VBoxStubBld
+VBoxStubBld_TEMPLATE= VBoxBldProg
+VBoxStubBld_DEFS = _WIN32_WINNT=0x0400 VBOX_SVN_REV=$(VBOX_SVN_REV) $(VBOX_SVN_REV_KMK)
+VBoxStubBld_SOURCES = VBoxStubBld.cpp
+
+include $(FILE_KBUILD_SUB_FOOTER)
+