summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules34
1 files changed, 34 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..0c06b97
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,34 @@
+#!/usr/bin/make -f
+
+DOPACKAGES = $(shell dh_listpackages)
+export PYBUILD_DESTDIR=debian/tmp
+
+# Make it easier to build on machines with ansible << 2.10 installed.
+export ANSIBLE_SKIP_CONFLICT_CHECK=1
+
+# tmpdir is needed during docs build, as ~ isn't writeable in sbuild
+export ANSIBLE_LOCAL_TEMP=tmp/
+
+%:
+# dh $@ --with python3,sphinxdoc --buildsystem=pybuild
+ dh $@ --with python3 --buildsystem=pybuild
+
+override_dh_clean:
+ dh_clean \
+ --exclude=test/units/inventory_test_data/group_vars/noparse/all.yml~ \
+ --exclude=test/integration/targets/collections/collection_root_user/ansible_collections/testns/testcoll/plugins/modules/uses_leaf_mu_flat_import.bak
+
+execute_after_dh_auto_build:
+ # manpage documentation
+ $(MAKE) docs
+ifneq (,$(filter ansible-doc,$(DOPACKAGES)))
+ # html documentation
+ $(MAKE) webdocs
+endif
+
+override_dh_auto_test:
+ # For now, disable the tests
+ #make tests-nonet
+
+override_dh_python3:
+ dh_python3 --shebang=/usr/bin/python3