summaryrefslogtreecommitdiffstats
path: root/docs/docsite/Makefile.sphinx
diff options
context:
space:
mode:
Diffstat (limited to 'docs/docsite/Makefile.sphinx')
-rw-r--r--docs/docsite/Makefile.sphinx26
1 files changed, 26 insertions, 0 deletions
diff --git a/docs/docsite/Makefile.sphinx b/docs/docsite/Makefile.sphinx
new file mode 100644
index 0000000..3bae705
--- /dev/null
+++ b/docs/docsite/Makefile.sphinx
@@ -0,0 +1,26 @@
+# Minimal makefile for Sphinx documentation
+#
+
+# You can set these variables from the command line.
+SPHINXCONFDIR = rst
+LANGOPTS ?=
+SPHINXOPTS ?= -j $(CPUS) -n -w rst_warnings -c "$(SPHINXCONFDIR)" $(LANGOPTS)
+SPHINXBUILD = sphinx-build
+SPHINXPROJ = sdfsdf
+SOURCEDIR = rst
+
+# Sets the build output directory if it's not specified on the command line
+ifndef BUILDDIR
+ BUILDDIR = _build
+endif
+
+# Put it first so that "make" without argument is like "make help".
+help:
+ $(SPHINXBUILD) -M help "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)
+
+.PHONY: help Makefile.sphinx
+
+# Catch-all target: route all unknown targets to Sphinx using the new
+# "make mode" option. $(O) is meant as a shortcut for $(SPHINXOPTS).
+%: Makefile.sphinx
+ $(SPHINXBUILD) -M $@ "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)