summaryrefslogtreecommitdiffstats
path: root/test/ansible_test/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'test/ansible_test/Makefile')
-rw-r--r--test/ansible_test/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/test/ansible_test/Makefile b/test/ansible_test/Makefile
new file mode 100644
index 0000000..2d85e3d
--- /dev/null
+++ b/test/ansible_test/Makefile
@@ -0,0 +1,13 @@
+all: sanity unit validate-modules-unit
+
+.PHONY: sanity
+sanity:
+ $(abspath ${CURDIR}/../../bin/ansible-test) sanity test/lib/ ${FLAGS}
+
+.PHONY: unit
+unit:
+ PYTHONPATH=$(abspath ${CURDIR}/../lib) pytest unit ${FLAGS}
+
+.PHONY: validate-modules-unit
+validate-modules-unit:
+ PYTHONPATH=$(abspath ${CURDIR}/../lib/ansible_test/_util/controller/sanity/validate-modules):$(abspath ${CURDIR}/../../lib) pytest validate-modules-unit ${FLAGS}