summaryrefslogtreecommitdiffstats
path: root/test/integration/targets/binary_modules/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'test/integration/targets/binary_modules/Makefile')
-rw-r--r--test/integration/targets/binary_modules/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/test/integration/targets/binary_modules/Makefile b/test/integration/targets/binary_modules/Makefile
new file mode 100644
index 0000000..398866f
--- /dev/null
+++ b/test/integration/targets/binary_modules/Makefile
@@ -0,0 +1,15 @@
+.PHONY: all clean
+
+all:
+ # Compiled versions of these binary modules are available at the url below.
+ # This avoids a dependency on go and keeps the binaries out of our git repository.
+ # https://ci-files.testing.ansible.com/test/integration/roles/test_binary_modules/
+ cd library; \
+ GOOS=linux GOARCH=amd64 go build -o helloworld_linux_x86_64 helloworld.go; \
+ GOOS=linux GOARCH=ppc64le go build -o helloworld_linux_ppc64le helloworld.go; \
+ GOOS=windows GOARCH=amd64 go build -o helloworld_win32nt_64-bit.exe helloworld.go; \
+ GOOS=darwin GOARCH=amd64 go build -o helloworld_darwin_x86_64 helloworld.go; \
+ GOOS=freebsd GOARCH=amd64 go build -o helloworld_freebsd_amd64 helloworld.go
+
+clean:
+ rm -f library/helloworld_*